AleksandrovnaIgor
?>

A. Одинаковые коды Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод samecode.in Вывод samecode.out На вход программе подаются результаты эксперимента - несколько строк с кодами, разделенными запятыми или пробелами. Строки нумеруются с 1. Ваша задача - написать программу, выводящую сумму номеров строк, в которых последний код первой строки встречается в них столько-же раз, сколько он встречается в первой строке. Формат ввода Первая строка входного файла samecode.in (*) содержит число n - количество строк, полученных в результате эксперимента и через пробел дату эксперимента в формате чч:мм:. (1 Формат вывода В единственную строку файла входного файла samecode.out (*) следует вывести ответ к задаче. * Уважаемые участники олимпиады, если в день основного тура вы выбрали решать олимпиаду по комплекту задач "7-8 понимая, что тем самым теряете возможность участия в региональном этапе ВОШ, то у Вас во время основного тура, как-же, как и сейчас, будет возможность считывать данные со стандартного потока, т.е. с клавиатуры и выводить ответ на экран. Для всех остальных участников, которые пишут олимпиаду по основному комплекту "9-11 возможности работать со стандартным потоком ввода - вывода на основном этапе не будет. Пример Ввод 5 26.11.2018 789 ugf ft4 tyu ft4 7876 ft4 iuh ft4, iyv 7876 ytf ytf 765f ft4, jhf 5676 ft4, jhg ft4, ju ytrdytrty999 gy ft4 765 ft4 hgft4 u76 ft4 drt Вывод 8

Информатика

Ответы

maximovpavel9114
ответ:  17

// delete.cpp: определяет точку входа для консольного приложения.//
#include "stdafx.h"#include "iostream"#include <conio.h>
using namespace std;
int count_ = 0;
char m[6][6] = { {'S', '.', '.', '.', '#', '#'}, { '#', '.', '#', '.', '.', '.' }, { '.', '.', '#', '.', '.', '#' }, { '.', '.', '#', '#', '#', '.' }, { '#', '.', '.', '.', '#', '#' }, { '#', '#', '#', '.', '.', 'F' }};
int find_p(int x, int y) { if (x < 0 || x > 5 || y < 0 || y > 5) return 0; if (m[y][x] == 'F') return 1; if (m[y][x] != '.' && m[y][x] != 'S') return 0; m[y][x] = '+'; count_++; if (find_p(x, y - 1)) return 1; if (find_p(x + 1, y)) return 1; if (find_p(x, y + 1)) return 1; if (find_p(x - 1, y)) return 1; m[y][x] = 'x'; return 0;}

int main(){ find_p(0, 0); cout << count_; //вывод _getch(); // задержка    return 0;}
Aksinya1036

n - входной параметр программы. нужно посчитать сколько действий выполняет программа в зависимости от n.

Например, если программа выполняет ограниченное количество действий - вне зависимости от n она будет считаться конечное время. А если есть какие-нибудь циклы - время выполнения программы будет расти в зависимости от параметра.

 

пример 1: программа вычисления площади квадрата по его стороне.

два действия - перемножить два числа и вывести результат. F(n) = 2;

 

пример 2: программа вычисления факториала:

присваиваем результату 1

сравниваем n<2.

если верно - печатаем результат и выходим

иначе результат := результат * n

    n:=n-1

и снова на сравнение

 

здесь F(n) = 1{начальное присвоение} + 3(n-1){сравнение и присвоения в цикле, который выполняется n-1 раза} + 1 {вывод результата} = 3n - 1

т.е время работы программы линейно возрастает при увеличении n

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

A. Одинаковые коды Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод samecode.in Вывод samecode.out На вход программе подаются результаты эксперимента - несколько строк с кодами, разделенными запятыми или пробелами. Строки нумеруются с 1. Ваша задача - написать программу, выводящую сумму номеров строк, в которых последний код первой строки встречается в них столько-же раз, сколько он встречается в первой строке. Формат ввода Первая строка входного файла samecode.in (*) содержит число n - количество строк, полученных в результате эксперимента и через пробел дату эксперимента в формате чч:мм:. (1 Формат вывода В единственную строку файла входного файла samecode.out (*) следует вывести ответ к задаче. * Уважаемые участники олимпиады, если в день основного тура вы выбрали решать олимпиаду по комплекту задач "7-8 понимая, что тем самым теряете возможность участия в региональном этапе ВОШ, то у Вас во время основного тура, как-же, как и сейчас, будет возможность считывать данные со стандартного потока, т.е. с клавиатуры и выводить ответ на экран. Для всех остальных участников, которые пишут олимпиаду по основному комплекту "9-11 возможности работать со стандартным потоком ввода - вывода на основном этапе не будет. Пример Ввод 5 26.11.2018 789 ugf ft4 tyu ft4 7876 ft4 iuh ft4, iyv 7876 ytf ytf 765f ft4, jhf 5676 ft4, jhg ft4, ju ytrdytrty999 gy ft4 765 ft4 hgft4 u76 ft4 drt Вывод 8
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

baranovaas
tochkamail7
Евгений
mulyugina365
Kashtanov Anna
jim2k
linda3930
stusha78938
Romanovich1658
vladexi
gumirovane2294
sbarichev330
delta88
olarina6510
orbbsvsupply
▲