naromanova
?>

Нужно написать программу на паскале.Создать файл действительных случайных чисел. Найти наибольший и наименьший элементы и дописать в файл

Информатика

Ответы

bchukhraev79

===== PascalABC.NET =====

begin

 var f := CreateFile&<real>('MyFile.bin');

 // создаем и заполняем файл

 loop 10 do // файл на 10 чисел

   Write(f, Random(100.0));

 // ищем минимум и максимум

 var (min, max) := (200.0, -100.0);

 f.Seek(0);

 var t: real;

 while not f.Eof do

 begin

   Read(f, t);

   if t > max then

     max := t

   else if t < min then

     min := t;

 end;

 // дозапись в файл

 Write(f, max);

 Write(f, min);

 // если надо - контрольный вывод

 f.Seek(0);

 while not f.Eof do

 begin

   Read(f,t);

   Print(t)

 end;

 // закрыть файл

 f.Close;

end.


Нужно написать программу на паскале.Создать файл действительных случайных чисел. Найти наибольший и
Vladimirovich Aleksandr1889
Const nx=30;var i,j,p,n:integer;A:array[1..nx,1..nx] of integer;d,Sn,min:real;begin p:=1;write('Введите размер матрицы');Read(n);for i:=1 to n do beginfor j:=1 to n do beginA[i,j]:=random(3)-2;write(A[i,j]:4);end;writeln;end;writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif i = j then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif (i= n -j +1) then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);end.
servik78
Const n = 5;
  m = 5;
var a:array[1..n,1..m] of integer;
i,j,s:integer;
begin
//Для теста заполним массив сл.числами
  for i:=1 to n do begin
    for j:=1 to m do begin
      a[i,j]:=random(21)-10; write(a[i,j]:4);
    end;
    writeln;writeln;
  end;
  //сумма всех элементов массива
  for i:=1 to n do
    for j:=1 to m do s:=s+a[i,j];
writeln('сумма всех элементов массива: ',s);
//сумма каждой строки
for i:=1 to n do begin
    s:=0;
    for j:=1 to m do begin
      s:=s+a[i,j];
    end;
    writeln ('Строка: ',i,' сумма:',s);
  end;   
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу на паскале.Создать файл действительных случайных чисел. Найти наибольший и наименьший элементы и дописать в файл
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

verachus
kchapurina591
gorushko-tabak3
Kochereva-Sergei
Nataliatkachenko1
Виктория1690
Nefedova1432
zaschitin48
toxicfish
Reginahappy
lokos201272
sv-opt0076
sttig
Yelena_Gennadevna
lbeglarova6