Поделитесь своими знаниями, ответьте на вопрос:
Спо информатике 9 класс. 1) составьте программу заполнения массива а 1..10 случайными целыми числами в диапозоне от n до m. числа n и m введите с клавиатуры вывидите на экран полученный массив 2)составьте программу заполнения массива a[1..10] следуюзими числами: индекс элемента: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 значение элемента: 3, 5, 7, 9, 11, 13, 15, 17, 19, 21 закономерность: для каждого элемента массива его значение равно удвоенному индексу, увеличенному на 1. 3) составьте программу заполнения массива a{1..10] числами фибоначчи. в последовательности фибоначчи значения первых двух элементов равны 1, а значение каждого последующего элемента, начиная с третьего, равно сумме двух предыдущих. индекс элемента: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 значение элемента: 1, 1, 2, 3, 5, 8, 13, 21, 34, 55
const k=10;
var a:array[1..k] of integer;
n,m,i:integer;
begin
// 1
write('n, m: ');
readln(n,m);
for i:=1 to k do
begin
a[i]:=random(m-n+1)+n;
write(a[i],' ');
end;
writeln;
// 2
for i:=1 to k do
begin
a[i]:=2*i+1;
write(a[i],' ');
end;
writeln;
// 3
a[1]:=1; a[2]:=1;
write(a[1],' ',a[2],' ');
for i:=3 to k do
begin
a[i]:=a[i-2]+a[i-1];
write(a[i],' ');
end;
writeln;
end.
Пример:
n, m: 5 15
5 6 11 8 6 14 8 7 9 10
3 5 7 9 11 13 15 17 19 21
1 1 2 3 5 8 13 21 34 55