Аверьянова
?>

Написать программу которая выводит на экран фразу < > или < > в зависимости от введенного числа n(n< > 0 в паскале

Информатика

Ответы

aa276568

ВОТ ЛОВИ РЕШЕНИЕ:

Удачи в будуйщем


Написать программу которая выводит на экран фразу < > или < > в зависимости от введенног
tiv67
PROGRAM MatrixMax
var a : array [1..3, 1..4] of integer
b : array [1..3] of integer
Max, i, j : integer
BEGIN
crt;
for i:=1 to 3 do 
begin
for j:=1 to 4 do
begin
read (a[i, j]); // вводим элементы в массив a[1..3, 1..4]
end;
writeln; // делаем пустой перевод строки
end;
for i:=1 to 3 do 
begin
b[i] := a[i, 1];
for j:=1 to 4 do
begin
if a[i, j] > b[i] then b[i] := a[i, j];
// находим максимальный элемент в каждой строке и записываем в b[1..3]
end;
end;
Max := b[1];
for i:=1 to 3 do if b[i] > Max then Max := b[i];
// Находим максимальный элемент из максимальных элементов
writeln (Max); // Выводим его на экран
END.
subbotinlan
// PascalABC.Net 3.0, версия 1066
const
  mm=50;
  nn=50;
var
  n,m,i,j,k1,k2,p:integer;
  s1,s2,s3:longint;
  a:array[1..mm,1..nn] of integer;
begin
  Write('Число строк и столбцов массива: '); Read(m,n);
  Write('Значение p: '); Read(p);
  Writeln('*** Сгенерированный массив ***');
  Randomize;
  s1:=0; s2:=0; s3:=0; k1:=0; k2:=0;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(101)-50;
      Write(a[i,j]:4);
      if a[i,j]>30 then s1:=s1+a[i,j];
      if Odd(a[i,j]) then Inc(k1)
      else begin s2:=s2+a[i,j]; Inc(k2) end;
      if i+j=p then s3:=s3+a[i,j]
      end;
    Writeln
  end;
  Writeln('Сумма элементов массива, больших 30: ',s1);
  Writeln('Количество нечетных элементов массива: ',k1);
  Writeln('Среднее арифметическое четных элементов массива: ',s2/k2);
  Writeln('Сумма элементов массива c суммой индексов ',p,': ',s3)
end.

Тестовое решение:
Число строк и столбцов массива: 8 10
Значение p: 13
*** Сгенерированный массив ***
 -19 -39 -46  12  41  44 -44  21  11  25
  13 -22   2  36  21 -42  34  15   5  25
  -6  -3 -33 -29  47 -44  33   5  27  23
  14  46  39 -35 -39  -1 -50  49   1  13
  -4 -14  28  40 -34  48   0  -9 -36  12
  -4 -20  35  45 -21  35  44  33  15  34
 -40   2  44  38 -40  18 -11 -14  24 -28
 -42  36 -37  42 -21 -43  19 -22 -45  49
Сумма элементов массива, больших 30: 892
Количество нечетных элементов массива: 40
Среднее арифметическое четных элементов массива: 1.15
Сумма элементов массива c суммой индексов 13: 56

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая выводит на экран фразу < > или < > в зависимости от введенного числа n(n< > 0 в паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

АнжелаВасильевич
artemkolchanov24
ariyskayaa5
a580028r
keshka12719
Larax0819
pokupatel688
artmasterstyle
mikek0906
krutikovas
Tatyana1374
Reutskii884
nzagrebin363
gallush9
Sergeevich-irina