Поделитесь своими знаниями, ответьте на вопрос:
Написать программу на питоне, которая будет разбивать введённое количество долларов/рублей рандомно на монетки. например: пользователь ввел 39.51$, программа выводит: 39.51$ = 10 монет по 25 центов, 3 монеты по 1 центу и т.д.
// Внимание! Если программа не работает, обновите версию!
begin
var x:=ArrGen(8,i->Ln(i+1.1)); x.Println;
var k:=x.Where(t->(Sin(t)>-0.5) and (Sin(t)<=0)).Count;
var im:=x.IndexMin;
Writeln('На указанном интервале найдено элементов: ',k);
Writeln('Минимальный элемент массива, равный ',x[im],
' имеет порядковый номер ',im+1)
end.
Результат
0.0953101798043249 0.741937344729377 1.1314021114911 1.41098697371026 1.62924053973028 1.80828877117927 1.96009478404727 2.09186406167839
На указанном интервале найдено элементов: 0
Минимальный элемент массива, равный 0.0953101798043249 имеет порядковый номер 1