frame45
?>

Машина тьюринга. перенести первый символ в конец слова. a={a, b, c}. пусть p - не пустое конечное слово более чем из 1-ого символа. необходимо составить программу, которая перенесет первый символ слова в его конец. начальное и конечное положение каретки – первый символ слова. если решаете, то будьте добры кинуть скриншот.

Информатика

Ответы

АндреевичОльга641

Запомнить первый символ входного слова, не стирая его (перейти в состояние q1, если первый символ – a, q3, если первый символ – b и q5, если первый символ – c).


Переместить автомат под последний символ и сравнить его с запомненным (в q2 для a, в q4 для b и в q6 для c). Если они равны, то больше ничего не делать.


В противном случае уничтожить всё входное слово (q7).

slastena69678

#include <iostream>

#include <algorithm>

using namespace std;

signed main(){

   ios_base::sync_with_stdio(false); cin.tie(nullptr); cout.tie(nullptr);

   long long n, mx1 = -1e10, mx2 = -1e10, mx3 = -1e10, mn1 = 1e10, mn2 = 1e10;

   cin >> n;

   for(int i = 0; i < n; i++){

       long long x;

       cin >> x;

       if(x > mx1){

           mx3 = mx2;

           mx2 = mx1;

           mx1 = x;

       }

       else if(x > mx2){

           mx3 = mx2;

           mx2 = x;

       }

       else if(x > mx3)

           mx3 = x;

       if(x < mn1){

           mn2 = mn1;

           mn1 = x;

       }

       else if(x < mn2)

           mn2 = x;

   }

   cout << max(mx1 * mx2 * mx3, mn1 * mn2 * mx1);

}

snezhanaklimenkova

Launcher.exe - это исполняемый файл (программа) для Windows. Расширение имени файла .exe - это аббревиатура от англ. слова executable — исполнимый. Необходимо запускать исполняемые файлы от проверенных производителей программ, потому что исполняемые файлы могут потенциально изменить настройки компьютера или нанести вред вашему компьютеру. Бесплатный форум с информацией о файлах может вам разобраться является ли launcher.exe вирусом, трояном, программой-шпионом, рекламой, которую вы можете удалить, или файл принадлежит системе Windows или приложению, которому можно доверять.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Машина тьюринга. перенести первый символ в конец слова. a={a, b, c}. пусть p - не пустое конечное слово более чем из 1-ого символа. необходимо составить программу, которая перенесет первый символ слова в его конец. начальное и конечное положение каретки – первый символ слова. если решаете, то будьте добры кинуть скриншот.
Ваше имя (никнейм)*
Email*
Комментарий*