nastikak8
?>

Паскаль: дан текст. слова в тексте разделены одним или несколькими пробелами. написать программу, выводящую все слова, начинающиеся с гласных букв алфавита.

Информатика

Ответы

Nikolaevich824
var
i:integer;
s:string;
const
glas=['Й','У','Е','Ы','А','О','Э','Я','И','Ю'];
beginwrite ('Vvedite predlohenie: ');
readln (s);
i:=1;
while i<=length (s) do     
begin           
if ((i=1) or (s[i-1]=' ')) and (s[i] in glas) then           
begin             
while not ((s[i] in ['.',',',';','!','?',':',' '])) and (i<=length (s)) do                   
begin                         
write (s[i]);                         
i:=i+1;                   
end;             
writeln;           
end;         
i:=i+1;     
end;
readln;
end.
qwe54344

Код:

using System;

namespace WordsCounter

{

   class Bishop

   {

       private int x, y;

       public Bishop(int x, int y)

       {

           this.x = x;

           this.y = y;

       }

       public bool CanIAttackIt(int x, int y)

       {

           return Math.Abs(x - y) == Math.Abs(this.x - this.y);

       }

   }

   class Program

   {

       static void Main(string[] args)

       {

           var x0 = int.Parse(Console.ReadLine()!);

           var y0 = int.Parse(Console.ReadLine()!);

           var x = int.Parse(Console.ReadLine()!);

           var y = int.Parse(Console.ReadLine()!);

           Console.WriteLine((new Bishop(x0, y0)).CanIAttackIt(x, y));

       }

   }

}


На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
shoora

Код:

using System;

namespace WordsCounter

{

   class Bishop

   {

       private int x, y;

       public Bishop(int x, int y)

       {

           this.x = x;

           this.y = y;

       }

       public bool CanIAttackIt(int x, int y)

       {

           return Math.Abs(x - y) == Math.Abs(this.x - this.y);

       }

   }

   class Program

   {

       static void Main(string[] args)

       {

           var x0 = int.Parse(Console.ReadLine()!);

           var y0 = int.Parse(Console.ReadLine()!);

           var x = int.Parse(Console.ReadLine()!);

           var y = int.Parse(Console.ReadLine()!);

           Console.WriteLine((new Bishop(x0, y0)).CanIAttackIt(x, y));

       }

   }

}


На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль: дан текст. слова в тексте разделены одним или несколькими пробелами. написать программу, выводящую все слова, начинающиеся с гласных букв алфавита.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

annanas08
Александра Викторович531
sadinuraliev263
Sergei
zdv686857
dubaiexport
ohussyev
md-masya
ksv89
Shevtsov1818
yuklimochkina3
melnik-738
Yarovitsin
Snimshchikov465
bureiko