stratocasterr34
?>

, у меня экзамен. Язык программирования - Python. 1 Уровень Задача 1 – Пользователь должен ввести логин и пароль. Длина логина от 5 до 10 символов. Длина пароля не менее 8 символов. Спрашивать у пользователя логин, пока он не введет подходящий. Только после этого спросить пароль. Спрашивать пароль, пока он не введет подходящий. Задача 2 – Напишите программу, которая 5 раз запрашивает у пользователя границы диапазона и выводит на экран подходящее целое случайное число в данном диапазоне. Задача 3 – Напишите программу, которая 5 раз запрашивает у пользователя границы диапазона и выводит на экран подходящее целое случайное число в данном диапазоне. Задача 4 – 1. Пользователь вводит строку не менее 15 символов (проверить на эту минимальную длину и при несоблюдении выдать ошибку) 2. Выведите 2 предпоследних символа этой строки 3. Выведите 5 символ этой строки 4. Выведите первые 8 символов этой строки 5. Выведите всю строку, кроме последних трех символов Задача 5 – • Создайте список names из 10 имен • Создайте список numbers из 15 целых чисел • Выведите имена из списка names с четными индексами • Выведите числа из списка numbers, которые больше 10

Информатика

Ответы

Тимур

ответ: См. снимок экрана (код в объяснении)

Объяснение:

from getpass import getpass

from random import randint

def task1():

   while True:

       log = input('Login: ')

       if len(log) >= 5 and len(log) <= 10:

           break

   while True:

       pswrd = getpass('Password: ')

       if len(pswrd) >= 8:

           print('Logged in succesfully!')

           break

def task2():

   for i in range(5):

       a = int(input("Enter the start: "))

       b = int(input("Enter the end: "))

       print(randint(a, b))

def task4():

   s = input("Enter the string: ")

   if len(s) < 8:

       quit()

   print('1.', s[-3:-1])

   print('2.', s[4])

   print('3.', s[:8])

   print('4.', s[:-3])

def task5():

   names = ['Liam', 'Noah', 'Oliver', 'William', 'Elijah',

            'James', 'Benjamin', 'Lucas', 'Mason', 'Ethan']

   numbers = []

   for i in range(15):

       numbers.append(randint(1, 100))

   for j in range(0, 10, 2):

       print(names[j])

   for k in range(15):

       if numbers[k] > 10:

           print(numbers[k])


, у меня экзамен. Язык программирования - Python. 1 Уровень Задача 1 – Пользователь должен ввести л
bhg50

ответ:1. прикладное ПО, системное и операционные системы  

2. ОС - комплекс управляющих и обрабатывающих программ, которые, с одной стороны, выступают как интерфейс между устройствами вычислительной системы и прикладными программами  

3. Интерфейс, Диалоговый режим взаимодействия пользователя или оператора с ЭВМ, при котором происходит непосредственный и двухсторонний обмен информацией, командами или инструкциями между человеком и ЭВМ.  

4. Системой программирования называется комплекс программ, предназначенный для автоматизации программирования задач на ЭВМ . Предназначены для разработчиков ПО и системных программистов.

Объяснение:

aprelevka

Мощность алфавита = 8.

Объяснение:

На заметку: Мощность алфавита — количество символов в нём.

По условию известно, что в каждой строке сообщения (их всего три) по 256 символов. Узнаем общее количество символов, умножив 3 на 256:

1) 3 * 256 = 768 — символов во всём сообщении.

Также нам известен общий информационный объём всего сообщения, равный 0,25 килобайта. Чтобы счёт в будущем был более удобным, можно перевести килобайты в биты, умножив 0,25 на 1024 (1 килобайт равен 1024 байтам) на 8 (1 байт равен 8 битам):

2) 0,25 * 1024 * 8 = 2048 — вес всего сообщения в битах.

Далее, чтобы узнать вес одного символа, достаточно просто поделить общий вес сообщения на количество символов, то есть 2048 на 768:

3) 2048 : 768 = 2,(6) ≈ 3 — вес одного символа.

В последнем шаге нужно воспользоваться формулой количества возможных событий и количества информации (N = 2^i, где N — количество возможных событий (в данном случае — мощность алфавита), а i — вес одного символа).

4) N = 2^3 = 8.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

, у меня экзамен. Язык программирования - Python. 1 Уровень Задача 1 – Пользователь должен ввести логин и пароль. Длина логина от 5 до 10 символов. Длина пароля не менее 8 символов. Спрашивать у пользователя логин, пока он не введет подходящий. Только после этого спросить пароль. Спрашивать пароль, пока он не введет подходящий. Задача 2 – Напишите программу, которая 5 раз запрашивает у пользователя границы диапазона и выводит на экран подходящее целое случайное число в данном диапазоне. Задача 3 – Напишите программу, которая 5 раз запрашивает у пользователя границы диапазона и выводит на экран подходящее целое случайное число в данном диапазоне. Задача 4 – 1. Пользователь вводит строку не менее 15 символов (проверить на эту минимальную длину и при несоблюдении выдать ошибку) 2. Выведите 2 предпоследних символа этой строки 3. Выведите 5 символ этой строки 4. Выведите первые 8 символов этой строки 5. Выведите всю строку, кроме последних трех символов Задача 5 – • Создайте список names из 10 имен • Создайте список numbers из 15 целых чисел • Выведите имена из списка names с четными индексами • Выведите числа из списка numbers, которые больше 10
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mirogall
Ligaevruslan
chaa140
shmidt
egcuzn86
Алена
keti0290103
ГегамБукреев830
Михайловна-Гусева350
martinson1136
chechina6646
cheremetdiana
svetlanam81
fakelel
ngoncharov573
▲