goldglobustour725
?>

Массив A заполнили, а потом изменили: n := 100; for i := 1 to n do A[i] := i; for i := 1 to n div 2 do A[i] := A[n + 1 - i]; Чему равна сумма первого и последнего элементов полученного в итоге массива?

Информатика

Ответы

ГегамБукреев830
ответ:

200

Объяснение:n := 100;

Присваиваем переменной n значение 100.

for i := 1 to n do  A[i] := i;

Объявляем цикл от 1 до n, то есть до 100, который будет присваивать элементу массива с индексом i новое значение: i. То есть мы просто пробегаемся по элементам массива от 1го до 100го и присваиваем им свой номер (индекс). То есть теперь A[1]=1, A[2]=2, A[3]=3 и т.д. до 100.

for i := 1 to (n div 2) do  A[i] := A[n + 1 - i];

Объявляем цикл от 1 до целой части от деления n на 2, то есть до 50, который будет присваивать элементу массива с индексом i новое значение: n + 1 - i. У нас n=100, поэтому новое значение каждого от 1го до 50го элемента массива будет равно: 101 - i, где i - номер (индекс) элемента. То есть теперь A[1]=101-1=100, A[2]=101-2=99, A[3]=98 и т.д. до 50.

Чему равна сумма первого и последнего элементов полученного в итоге массива? A[1] = 100, а A[100] = 100. ответ: 100 + 100 = 200.

P7Y7V7

Так как изначально в задании указано : "на любом известном вам языке программирования" - вот, держи на С.

#include <stdio.h>

#include <stdlib.h>

#include <locale.h>

#define N 100

int main()

{

setlocale(LC_ALL, "Rus");

int i, M;

float B[N], MIN;

printf(" Введите количество элементов массива (не больше 100) => ");

scanf("%d", &M);

if (M < 100)

{

for (i = 0; i < M; i++)

{

printf("Введите [%d] элемент массива =>", i);

scanf("%f", &B[i]);

}

for (i = 0; i < M; i++)

printf("%1.0f ", B[i]);

MIN=B[0];

for (int i=1; i<M; i++)

{

if (B[i]<MIN)

MIN=B[i];

}

printf ("\n\tМинимальное значение в массиве => %7.2f", MIN);

}

else

printf("Ошибка. Заданное число элементов массива слишком большое.");

return 0;

}

bellenru

1Найдите значение выражения 8F – 80 в шестнадцатеричной системе счисления. В ответе запишите вычисленное значение в десятичной системе счисления.

Решение.

Переведём число 8F16 из шестнадцатеричной в десятичную систему счисления:

8F16 = 14310.

Переведём число 8016 из шестнадцатеричной в десятичную систему счисления:

8016 = 12810.

Найдём разность: 143 − 128 = 15.

2

Найдите значение выражения 1116 + 118 : 112. ответ запишите в двоичной системе счисления.

Решение.

Переведем все числа в десятичную систему счисления, выполним действия и переведем результат в двоичную систему счисления:

1116 = 16 + 1 = 1710,

118 = 8 + 1 = 910,

112 = 2 + 1 = 310,

17 + 9 : 3 = 17 + 3 = 2010,

20 = 16 + 4 = 10100 и маленькая два вместе с ответом

3

Вычислите значение выражения B916 − 2718. В ответе запишите вычисленное значение в десятичной системе счисления.

Ре­ше­ние.

Пе­ре­ведём числа в де­ся­тич­ную си­сте­му счис­ле­ния:

B916 = 18510

2718 = 18510

Найдём раз­ность: 185 − 185 = 0.

ответ дай лучшего ответа

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Массив A заполнили, а потом изменили: n := 100; for i := 1 to n do A[i] := i; for i := 1 to n div 2 do A[i] := A[n + 1 - i]; Чему равна сумма первого и последнего элементов полученного в итоге массива?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Veronika343
swetlanafatinia7323
kryshtall2276
mmurzina
kulagin777
zhunina71807
info-mosbalkon
teya07
Galiaahmatova4447
gaina6678
len4ik1986
testovvanya
Salkinserg
sv455umarketing74
▲