picassovrn
?>

1. С клавиатуры вводится число. Составить программу, которая увеличивает это число в два раза, если оно меньше пяти, и увеличивает его в три раза в противном случае. 2. Составить программу, которая возводит в квадрат большее из двух заданных чисел а и b. Вывести на экран оба числа.

Информатика

Ответы

aamer9992680

python

1)

a = int(input())

if a < 5:

 print(a * 2)

else:

 print(a * 3)

2)

a = int(input())

b = int(input())

if a >= b:

 print(a**2)

else:

 print(b**2)

PushkinaKurnosov984
//1
var A, B, i: integer;
begin
  write('Введите A и B: '); readln(A, B);
  for i := A to B do
    if ((i mod 3 = 0) and (i mod 10 = 3)) then writeln(i);
end.

//2
var
  A, B, i, k: integer;
begin
  write('Введите A и B: '); readln(A, B);
  for i := A to B do
    if ((i > 99) and (i < 1000)) and ((i mod 10 = 9) and (i mod 100 <> 99)) then
    begin
      writeln(i);
      k := k + 1;
    end;
    if k = 0 then writeln('Таких чисел нет.');
end.

//3
var sum, i, n: integer;
begin
  write('Введите количество предметов: '); readln(n);
  for i := 1 to n do
  begin
    readln(n);
    sum := sum + n;
  end;
  writeln('Общая масса = ', sum);
end.

//3 с другим циклом
var sum, n: integer;
begin
  writeln('Введите 0 для завершения ввода.');
  repeat
    readln(n);
    sum := sum + n;
  until n = 0;
  writeln('Общая масса = ', sum);
end.
yaart-klementiev29
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

№1

begin
  var (a,b):=ReadInteger2('Границы интервала [A,B]:');
  for var n:=a to b do
    if (Abs(n mod 10)=3) and (n mod 3=0) then Print(n)
end.

Пример
Границы интервала [A,B]: -50 142
-33 -3 3 33 63 93 123

№2

begin
  var (a,b):=ReadInteger2('Границы интервала [A,B]:');
  var k:=0;
  for var n:=a to b do begin
    var m:=Abs(n);
    if (m mod 10=9) and (m mod 100<>99) and (m>=100)
        and (m<=999) then begin Print(n); k+=1 end
    end;
  if k=0 then Writeln('Таких чисел нет') 
end.

Примеры
Границы интервала [A,B]: -200 160
-189 -179 -169 -159 -149 -139 -129 -119 -109 109 119 129 139 149 159

Границы интервала [A,B]: 52 101
Таких чисел нет

№3

begin
  var n:=ReadInteger('Введите количество предметов:');
  var m:=0.0;
  for var i:=1 to n do begin
    Write('Маcса предмета № ',i,': '); m+=ReadReal;
    end;
  Writeln('Масса груза равна ',m)
end.

Пример
Введите количество предметов: 5
Маcса предмета № 1: 24.62
Маcса предмета № 2: 8.1
Маcса предмета № 3: 132
Маcса предмета № 4: 24.5
Маcса предмета № 5: 52.7
Масса груза равна 241.92

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. С клавиатуры вводится число. Составить программу, которая увеличивает это число в два раза, если оно меньше пяти, и увеличивает его в три раза в противном случае. 2. Составить программу, которая возводит в квадрат большее из двух заданных чисел а и b. Вывести на экран оба числа.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

rinata542
Tselyaritskaya Yurevich
barkhatl-2p7
olgavbaranova
tanyamurashova11352
nikolai37
tyrnaus
ramco1972
sespiridonov
com4047797
smartschoolfili6
tanias
vakhitov100961
ams-sim
Ерохин
▲