ирина_Андреевич1634
?>

Решить задачи:программа+блок-схема 1.в спортивный кружок по баскетболу принимают детей возрастом от 10 до 14. написать программу, определяющую попадёт ли ребёнок в данную секцию2. Найти длину прямоугольника и его площадь, если известны его ширина и периметр. ​

Информатика

Ответы

iqtoy2010
Var
    a, b: real ;

begin
    Write('тормозной путь, определенного для данного места при полном служебном торможении = ');
    readln(a);
    Write('тормозной путь для на 120 км/ч для пассажирских поездов = ');
    readln(b);
    if b < a then a := b;
    Write('тормозной путь для на 80 км/ч для грузовых поездов = ');
    readln(b);
    if b < a then a := b;
    Write('тормозной путь при экстренном торможении с учетом пути, проходимого поездом за время, необходимое для воздействия устройств автоматической локомотивной сигнализации на тормозную систему поезда = ');
    readln(b);  
    if b > a then a := b;
    Write('участок, где видимость сигналов менее 400 м? да-1/нет-0 ');
    readln(b);
    if (b = 1) and (a < 1000) then a := 1000;
    Write('железнодорожная линия, вновь оборудуемая автоблокировкой? да-1/нет-0 ');
    readln(b);
    if (b = 1) and (a < 1000) then a := 1000;
    writeln(a);
end.
fullhouse9991
1. Традиционное решение

const
  n=10;
var
  x,y:array[1..n] of integer;
  sx,sy,i:integer;
begin
  Randomize;
  Write('X: ');
  sx:=0;
  for i:=1 to n do begin
    x[i]:=Random(101)-50;
    Write(x[i],' ');
    sx:=sx+x[i]
    end;
  Writeln;
  Write('Y: ');
  sy:=0;
  for i:=1 to n do begin
    y[i]:=Random(101)-50;
    Write(y[i],' ');
    sy:=sy+y[i]
    end;
  Writeln;
  Writeln('Сумма х= ',sx,', сумма y= ',sy);
  if sx>sy then for i:=1 to n do y[i]:=0
  else for i:=1 to n do x[i]:=0;
  Write('X: ');
  for i:=1 to n do Write(x[i],' ');
  Writeln;
  Write('Y: ');
  for i:=1 to n do Write(y[i],' ');
  Writeln
end.

Пример
X: 4 29 -50 -18 37 -43 -18 9 41 28
Y: -8 41 -18 -6 -10 -10 47 -8 -29 25
Сумма х= 19, сумма y= 24
X: 0 0 0 0 0 0 0 0 0 0
Y: -8 41 -18 -6 -10 -10 47 -8 -29 25

2. Аналогичное решение средствами PascalABC.Net 3.2

const
  n=10;
begin
  var x:=ArrRandom(n,-50,50); Write('X: '); x.Println;
  var y:=ArrRandom(n,-50,50); Write('Y: '); y.Println;
  var sx:=x.Sum; var sy:=y.Sum;
  Writeln('Сумма х= ',sx,', сумма y= ',sy);
  if sx>sy then y:=ArrFill(n,0) else x:=ArrFill(n,0);
  Write('X: '); x.Println;
  Write('Y: '); y.Println
end.

Выбирать вам...)))

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить задачи:программа+блок-схема 1.в спортивный кружок по баскетболу принимают детей возрастом от 10 до 14. написать программу, определяющую попадёт ли ребёнок в данную секцию2. Найти длину прямоугольника и его площадь, если известны его ширина и периметр. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ogonizoloto
annatarabaeva863
hacker-xx1
lanabogd
Smirnovav1982422
yurazharov
АркадьевичБундин789
asl09777
Марина555
lebedev815
mbudilina
Milovidova
sergeevna
volna22051964
zimin0082