Akolomaeva4
?>

Составьте программу, которая заполняет массив а [1..10] случайными числами в диапазоне от 10 до 40, затем меняет местами 4 и 7 элемент массива. это pascal, 9 класс

Информатика

Ответы

gen218
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,10,40); a.Println;
  Swap(a[3],a[6]); a.Println
end.

Пример
15 19 29 28 27 20 37 34 39 31
15 19 29 37 27 20 28 34 39 31

Составьте программу, которая заполняет массив а [1..10] случайными числами в диапазоне от 10 до 40,
озерская_Мария1234
Var
  A: array [1..10] of byte;
  i, tmp: byte;
begin
randomize;
  for i := 1 to 10 do
    A[i] := random(31)+10;
  writeln('Сгенерированный массив.');  
  for i := 1 to 10 do
    write(A[i],' ');
  tmp := A[7];
  A[7] := A[4];
  A[4] := tmp;
  writeln;
  writeln('Измененный массив.');
  for i := 1 to 10 do
    write(A[i], ' ');
end.
Vlad Petr531
Под блокнотом подразумевается стандартный Windows Notepad. Он прост как дважды два, и таким и задумывался. Предназначен для просмотра и возможно редактирования простых текстовых файлов(не документов, форматирование не изменяется), например .txt, .xml, .html и тд
Им можно открыть и посмотреть текстовое представление любого файла, хотя большие файлы он не откроет (зависнет или упадет) и может иметь проблемы с кодировками.
Имеет простейшие функции типа поиск, замена, переход. А так же открыть и сохранить файл.

Если часто приходится иметь дело с текстовыми файлами предназначеными в первую очередь для чтенье компьютером типа программных кодов, скриптов и тд, то рекомендуется использовать специализированные блокноты типа Notepad++, Sublime Text, Vim, Akelpad и тд

MSO Word предназначен для создания, просмотра, редактирования текстовых документов (не просто текстовых файлов) предназначеных в первую очередь для просмотра людьми. Потому очень много уделяется внимания форматированию текста, можно добавлять всякие рисунки, таблички и прочее и прочее
Можно редактировать и простые текстовые файлы, но это не удобно
Maksim Lokhov

Program Zn;

uses CRT;

type mas=array [1..20, 1..20] of real;

var A:mas; i,j,g,b,n,m,o:integer;   l:real;

Begin

     clrscr;

     write ('Введите диапазон массива: ');

     readln (g,b);

     write ('Введите размер массива: ');

     readln (n,m);

     Randomize;

     For i:=1 to n do

         Begin

          For j:=1 to m do

             Begin

                  A[i,j]:=random(b-g)+g;

                  write (A[i,j]:5:0, '  ');

             End;

             writeln;

         End;

     O:=0;

     For i:=1 to n do

       Begin

         For j:=1 to m do

             Begin

                  A[3,j]:=O;

             End;

       End;

     For i:=1 to n do

         Begin

           For j:=1 to m do

              If i=1 then

               Begin

                    L:=l+A[i,j];

               End;

         End;

     writeln ('Новый массив');

     For i:=1 to n do

        Begin

         For j:=1 to m do

             Begin

                  write (A[i,j]:5:0, '  ');

             End;

             writeln

        End;

        writeln ('Сумма элементов первой строки= ',l:5:0);

readln;

End.

 Вообщем вот.

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая заполняет массив а [1..10] случайными числами в диапазоне от 10 до 40, затем меняет местами 4 и 7 элемент массива. это pascal, 9 класс
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

АлександровнаВладимирович1424
bristolhouse20151001
Aleksandrovich1669
Donat-Evgeniya793
sergeykvik13
irinanikulshina144
pereverzev
Abespal
sergei641
joini09
topshopnails
Melnik Kaveshnikova1746
chermen40
saint158
Nasteona1994