mototeh69
?>

Составить программу, выводящую на экран все двузначные числа, у которых сумма цифр является четным числом.

Информатика

Ответы

is490
Var i:integer;
begin
for i:=10 to 99 do
 if (i div 10 + i mod 10) mod 2=0 then write(i,' ');
end.

Результат:
11 13 15 17 19 20 22 24 26 28 31 33 35 37 39 40 42 44 46 48 51 53 55 57 59 60 62 64 66 68 71 73 75 77 79 80 82 84 86 88 91 93 95 97 99
anazarov80
ПОСЛЕДОВАТЕЛЬНОСТЬ ФИБОНАЧЧИ, математическая ПОСЛЕДОВАТЕЛЬНОСТЬ, каждый член которой является суммой двух предыдущих. Таким образом, если энный член последовательности обозначается хn, то для всей последовательности справедливым будет уравнение: хn+2=хn+хn+1, первыми двумя членами которого будут x1=l и x2=1. Порядок последовательности при этом таков: 1, 1, 2, 3, 5, 8, 13, 21..., следующим числом будет 34, т. к. сумма 13 и 21 равна 34 и т.д. Когда число n становится очень большим, отношение соответствующих членов устремляется к величине (Ц5+l)/2. Это соотношение называется золотым. В природе последовательность Фибоначчи можно проследить на примерах спирального развития сегментов раковины и лепестков подсолнуха, расходящихся лучами из одной точки в центре цветка. см. также ЗОЛОТОЕ СЕЧЕНИЕ. 
vitalina3012
Top и Left определяют расстояние от границы поля до верхней и левой границы контейнера, в котором поле находится, соответственно. Name определяет системное имя поля, Color-цвет поля, Text-отображаемый текст на поле, Enabled-возможность взаимодействия с полем(к примеру кликнуть по полю), Visible-видимость поля, Font-шрифт отображаемого текста. Изменить текст в поле можно с метода setText("Строка"). Разместить поле на форме можно с метода add(<компонент>), или с визуального инструмента в Visual Studio, Qt Designer. И самое важное: поле нужно в программе для взаимодействия человека с программой, а так же настройки графического интерфейса. А вот отличие для поля и формы я не знаю((

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, выводящую на экран все двузначные числа, у которых сумма цифр является четным числом.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vasilevskii
gelena03
evoque2014
Никита
oliayur4encko
Васильева-Александрович
lk1303
corneewa20096
Троцкая-Ивановна
olyavoznyak
roma8
Viktorovich395
nestruev
akuznecov8989
atvkaprolon
▲