Lorik-lorik29
?>

Составьте программу которая формирует массив из 13 случайных чисел, от 0 до 30, меняет местами 4-й и 9-й элементы и выводит значения элементов массива на экран до и после обмена. pascal abc

Информатика

Ответы

printdecor
Const n=13;
var a:array[1..n] of integer;
i,c:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(31);
 write(a[i]:4);
 end;
writeln;
c:=a[4]; a[4]:=a[9]; a[9]:=c;
for i:=1 to n do write(a[i]:4);
writeln;
end.

Пример:
Массив A:
11 25 20 0 7 28 27 26 23 25 12 24 20
11 25 20 23 7 28 27 26 0 25 12 24 20
boldyrevanastia22
Монитор – устройство визуального отображения текстовой и графической информации, преобразует цифровую и (или) аналоговую информацию в видеоизображение.
Стандартный тип мониторов – это мониторы на основе электронно-лучевой трубки (ЭЛТ). Такой монитор по принципу работы ничем не отличается от обычного телевизора: пучок лучей, выбрасываемый электронной пушкой, падает на поверхность кинескопа, покрытую особым веществом – люминофором. Под действием этих каждая точка экрана светится одним из трёх цветов – красным, зелёным и синим. Технология эта старая. обкатанная в течении многих десятилетий, а потому ЭЛТ– мониторы сегодня – совершенные и недорогие устройства. На их стороне – отличная яркость и контрастность изображения, низкая цена, а следовательно, и доступность.Но есть и минусы – вес и габариты ЭЛТ-монитора ну никак не вписываются в сегодняшние представления о компьютере как о миниатюрном устройстве. Прибавьте сюда колоссальное энергопотребление, а также вредное воздействие излучения на пользователя.
Принтеры предназначены для вывода на бумагу (создания “твердой копии”) числовой, текстовой и графической информации. По своему принципу действия принтеры делятся на матричные, струйные и лазерные.
Матричные принтеры – это принтеры ударного действия. Печатающая головка матричного принтера состоит из вертикального столбца маленьких стержней (обычно 9 или 24), которые под воздействием магнитного поля “выталкиваются” из головки и ударяют по бумаге (через красящую ленту). Перемещаясь, печатающая головка оставляет на бумаге строку символов. Недостатки матричных принтеров состоят в том, что они печатают медленно, производят много шума и качество печати оставляет желать лучшего (соответствует примерно качеству пишущей машинки).
Cтруйные принтеры. В последние годы широкое распространение получили черно-белые и цветные струйные принтеры. В них используется чернильная печатающая головка, которая под давлением выбрасывает чернила из ряда мельчайших отверстий на бумагу. Перемещаясь вдоль бумаги, печатающая головка оставляет строку символов или полоску изображения. Струйные принтеры могут печатать достаточно быстро (до нескольких страниц в минуту) и производят мало шума. Качество печати (в том числе и цветной) определяется разрешающей струйных принтеров, которая может достигать фотографического качества 2400 dpi. Это означает, что полоска изображения по горизонтали длиной в 1 дюйм формируется из 2400 точек (чернильных капель).
Лазерные принтеры обеспечивают практически бесшумную печать. Высокую скорость печати (до 30 страниц в минуту) лазерные принтеры достигают за счет постраничной печати, при которой страница печатается сразу целиком. Высокое типографское качество печати лазерных принтеров обеспечивается за счет высокой разрешающей которая может достигать 1200 dpi и более.
Сканер – устройство, которое анализируя какой-либо объект (обычно изображение, текст), создаёт цифровую копию изображения объекта.
Ручные сканеры – обычные или самодвижущиеся – обрабатывают полосы документа шириной около 10 см и представляют интерес, прежде всего для владельцев мобильных ПК. Они медлительны, имеют низкие оптические разрешения (обычно 100 точек на дюйм) и часто сканируют изображения с перекосом. Но зато они недороги и компактны.
Планшетные сканеры более распространены на рынке, чем другие типы сканеров и имеют ряд преимуществ по объему применения, то есть более универсальны. Они напоминают верхнюю часть копировального аппарата: оригинал – либо бумажный документ, либо плоский предмет – кладут на специальное стекло, под которым перемещается каретка с оптикой и аналого-цифровым преобразователем (однако существуют “планшетники”, в которых перемещается стекло с оригиналом, а оптика и АПЦ остаются неподвижными, чем достигается более высокое качество сканирования).
Мышь – устройство управления манипуляторного типа. Перемещение мыши по плоской поверхности синхронизировано с перемещением графического объекта (указателя мыши) на экране монитора. Компьютером управляют перемещением мыши по плоскости и кратковременными нажатиями правой и левой кнопок (Эти нажатия называются щелчками.)
Механические мышки. В механических мышах информация о перемещении курсора формируется с резинового шарика, который касается поверхности стола и вращает два координатных валика – горизонтальный и вертикальный.
Радио-мышки. В настоящее время появились более современные – беспроводные радио-мышки, которые соединяются с системным блоком с радио-датчика (ресивера), подключенного к компьютерному порту.
mishamedbrat
Const   N = 10;   
var   a, S1, S2: Integer;   
i, Q1, Q2: Byte;   
begin   
S1 := 0; Q1 := 0;   
S2 := 0; Q2 := 0;  
writeln('Введите ', N, ' чисел:');   
for i := 1 to N do 
begin     
read(a);     
if a < 0 then 
begin      
S1 := S1 + a;       
inc(Q1)     
end;     
if a > 0 then 
begin       
S2 := S2 + a;       
inc(Q2)     
end;   
end;   
writeln;   
if Q1 > 0 then 
begin     
writeln('Сумма отрицательных чисел: ', S1);     
writeln('Количество отрицательных: ', Q1)   
end   
else 
writeln('Отрицательных нет');   
if Q2 > 0 then
begin     
writeln('Сумма положительных чисел: ', S2);     
writeln('Количество положительных: ', Q2)   
end   
else 
writeln('Положительных нет') 
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая формирует массив из 13 случайных чисел, от 0 до 30, меняет местами 4-й и 9-й элементы и выводит значения элементов массива на экран до и после обмена. pascal abc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Щуплова Александр
ElenaSkvortsova2
office
gardenkafe
pifpaf85
artem
loa364
elozinskaya
Лебедев972
svetlana-sharapova-762621
leeka152522
Кочугурова
Valerii276
kryukovaem
Andreevich440