Pokupatel
?>

Напишите программу к этой для visual basic имеется массив к из nцелых чисел. составьте алгоритм подсчета, сколько раз число 5 встречается среди элементов данного массива, иначе сообщить: «таких нет».

Информатика

Ответы

Васильевич Валерьевна
#include <iostream>
#include <vector>
using namespace std;
int main() {
int n, x, five = 0;
cin >> n;
vector <int> k;
for (; n > 0; cin >> x, k.emplace_back(x), n--);
for (int i = 0; i < k.size();) {
 if (k[i++] == 5)
  ++five;
}
if (five == 0)
 cout << "There is no such";
else
 cout << five;
return 0;
}
Azarova Anastasiya1707
Не больше - значит, меньше или равно. Они все сказали правду.
Среди них 0 брехунов, а это не больше 1, не больше 2, не больше 3 и не больше 4.
Причем тот, кто сказал "Не больше 4" - сказал правду, их же всего 4.
Если среди них есть один брехун, то опять-таки все сказали правду.
Потому что один - это не больше одного. Получаем противоречие.
Если среди них два брехуна, то соврал только один: который сказал
"Не больше одного". Опять противоречие.
Если брехунов трое, то соврали только двое, которые сказали
"Не больше 1" и "Не больше 2".
symkifm

using System;

namespace kp9p_pr_10_zad_6

{

   class Program

   {

       delegate void Square(double a1, double b1, double alfa1);

       static void Main(string[] args)

       {

           double a, b; // переменные для сторон a и b  

           double alpha; // переменная для угла альфа  

           Console.WriteLine("Введите значения треугольника:\n ");

           Console.Write("a: ");

           a = double.Parse(Console.ReadLine());   // ввод стороны a  

           Console.Write("b: ");

           b = double.Parse(Console.ReadLine()); // ввод стороны b  

           Console.Write("Угол альфа: ");

           alpha = double.Parse(Console.ReadLine()); // ввод угла альфа  

           sq(a, b, alpha);  

           static void sq(double a1, double b1, double alpha1) // функция sq расчета и вывода площади  

           {

               Console.WriteLine("\nПлощадь: {0}", (a1 * b1 * Math.Sin(alpha1)) / 2); // вывод и расчет площади  

           }

       }

   }

}  

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу к этой для visual basic имеется массив к из nцелых чисел. составьте алгоритм подсчета, сколько раз число 5 встречается среди элементов данного массива, иначе сообщить: «таких нет».
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vladimirovna Viktorovna
Петренко1852
Виктор-Богданов
fancy-decor67
Игорь Андрей
arteevdimon
Akopovich802
misie1974
forosrozhkov
cafemgimo
arturusinsk5
vorota-grupp
Vitalik6928
irschacha
steff77