oksana-popova
?>

Вмассиве хранится рост 10 учеников. составить программу, которая определяет, рост самого высокого ученика и его номер по списку.

Информатика

Ответы

aivia29
Если уже есть массив, и его надо отсортировать, то:

k = 1 //Номер ученика
h = 0
s = 0
For a in massive :
      if a > h:
          h = a
          s = k
      k += 1

print(h)
print(k)

//Реализация на питоне
dmitrijku
В заданій матриці розмірність якої вказує користувач , а елементи  утворюється випадковим чином ,потрібно,елементи матріць ,які не потрапляють в інтервал [a,b]записати в окремий вектор .Межі інтервалу ввести з клавіатури.нужно написать програму 
alfakurs

немного не по теме, но надеюсь, того, чего не хватает, ты сможешь дополнить самолично?блага тебе.

Объяснение:

Информатика- один из самых современных областей знаний и наук, также относящаяся к группе знаний, которыми мы пользуемся на чуть ли не постоянной основе и всю свою собственную жизнь, используя те или иные, изученные и освоенные навыки использования и работы.Каждый особенный день сталкиваемся с технологиями и ее последующими, и казалось бы, все основные техники работ и их услуг, цель работ мы прекрасно знаем, но не все понимают, что предмет "Информатика"—не просто сборище базовых знаний о телефонах и ПК устройств, а целый, огромный, много сервисный аккаунт, дающий на все интересующие и интеллектуальные вопросы технологичный и современный ответ.

Все окружающие вокруг нас- потоки и вихри новых глубин информаций, море познания и соответствующего опыта.Логически подумав, можно заключить разумную догадку: Наука Информатика- гениальный и интеллектуальный лидер этого "моря", умеющего умело управлять своим крепким судном и преданным экипажем.

Самое важное, что требуется знать каждому человеку, так это то, что без нашей матушки-Информатики и ее высших пиков достижения в изучении нового и совершенного, не бывало бы и нашей нынешних неодушевленных, верных -друзей, которыми мы регулярно пользуемся и доверяем им свои данные.Если бы не стремительное познание человека в вычислительных науках и личной, дикой любознательности к изучению новых, усовершенствованных понятий, мы бы не достигли культурных и кибернетических характеристик и опыта в ловких, умелых вещах.

golovins3

Можно при вводе фильтровать что вводится, если число не удовлетворяет требованиям оно игнорируется

var a: array[1..10] of integer;

n,c,i:integer;

inp : real;

begin

   readln(n);

   i:=1;

   repeat

       readln(inp);

       c := round(inp);

       if (inp = c) and (inp >= 0.0) and (inp <1001.0) then

           begin

               a[i]:= c;

               i:=i+1;

           end;

   until(i=n+1);

   

   c:=0;

   for i:= 1 to n do

       if a[i] < n then

           c:= a[i]+c;

   writeln(c);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вмассиве хранится рост 10 учеников. составить программу, которая определяет, рост самого высокого ученика и его номер по списку.
Ваше имя (никнейм)*
Email*
Комментарий*