shakovaea
?>

Составьте программу, которая позволяет ввести с клавиатуры две строки а и б, а затем определяет равны ли они. пример : голубь(строка а), лебедь ( строка б), пример вывода — да/нет.

Информатика

Ответы

perova-s200
Var
a,b:string;
c,k:integer;
begin
write ('Строка А:');readln (a);
write ('Строка В:');readln(b);
c:=length(a);k:=length(b);
if c = k then writeln ('YES')
elsewriteln ('NO')
end.
heodbxbbshe

Графи́ческий интерфе́йс по́льзователя (ГИП), графический пользовательский интерфейс (ГПИ) (англ. graphical user interface, GUI) — система средств для взаимодействия пользователя с компьютером, основанная на представлении всех доступных пользователю системных объектов и функций в виде графических компонентов экрана (окон, значков, меню, кнопок, списков и т. п.).

В отличие от интерфейса командной строки, в GUI пользователь имеет произвольный доступ (с устройств ввода — клавиатуры, мыши, джойстика и т. п.) ко всем видимым экранным объектам (элементам интерфейса) и осуществляет непосредственное манипулирование ими. Чаще всего элементы интерфейса в GUI реализованы на основе метафор и отображают их назначение и свойства, что облегчает понимание и освоение программ неподготовленными пользователями.

Графический интерфейс пользователя является частью пользовательского интерфейса и определяет взаимодействие с пользователем на уровне визуализированной информации.

Объяснение:

pronikov90

В 1623 году Вильгельм Шиккард придумал «Считающие часы» — первый арифмометр, умевший выполнять четыре арифметических действия. Считающими часами устройство было названо потому, что, как и в настоящих часах, работа механизма была основана на использовании звёздочек и шестерёнок. Это изобретение нашло практическое использование в руках друга Шиккарда, философа и астронома Иоганна Кеплера.

За этим последовали машины Блеза Паскаля («Паскалина», 1642 г.) и Готфрида Вильгельма Лейбница — арифмометр Лейбница.

Лейбниц также описал двоичную систему счисления — один из ключевых принципов построения всех современных компьютеров. Однако, вплоть до 1940-х многие последующие разработки (включая машины Чарльза Бэббиджа и даже ЭНИАК 1945 года) были основаны на более сложной в реализации десятичной системе.

В 1820 году Шарль Ксавье Тома де Кольмар создал первое серийно выпускавшееся механическое счётное устройство — арифмометр Томаса, который мог складывать, вычитать, умножать и делить. В основном, он был основан на работе Лейбница.

В 1845 году Израиль Штаффель представил счётную машину, которая кроме четырёх арифметических действий могла извлекать квадратные корни. Арифмометры, считающие десятичные числа, использовались до 1970-х.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая позволяет ввести с клавиатуры две строки а и б, а затем определяет равны ли они. пример : голубь(строка а), лебедь ( строка б), пример вывода — да/нет.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Irina-Tunyan
bronco-s
Azarova Anastasiya1707
Это по информатике 6 класс​
Низамов
westgti77105
dianabuchkina
gallush9
mereninka7008
АртакСергеевич1723
Yurevna419
majorovnatalya5
Николаевна1564
drontox1031
kol-nat26
aleksvasin