Var
N,A:integer;
Begin
Write('N = ');Read(N);
A:=0;
While N>0 do
Begin
if (N mod 10) > A then A:= N mod 10;
N:=N div 10;
End;
Write(A)
End.
Var
N,A,B:integer;
C:boolean;
Begin
Write('N = ');Read(N);
A:=-1;
B:=-2;
C:=false;
While N>0 do
Begin
if A=B then C:=true;
if N>0 then
Begin
A:=N mod 10;
N:=N div 10;
End;
if A=B then C:=true;
if N>0 then
Begin
B:=N mod 10;
N:=N div 10;
End;
End;
if A=B then C:=true;
if C then Write('Есть')
else Write('Нет')
End.
Подробнее - на -
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу на паскале, которое определяет является ли число простым? и ещё выводит те числа на которые делится.
a:= length(STROKA);
for I:= 1 to a do
if STROKA[I] == '.' then b:= true;
if b == true
Then
WriteLn('Ты чет ваще не прост.');
Else
c:= VAL(STROKA);
End;
For i:= c downto 1 do
if c mod I == 0 then Writeln(I);