zhmulyov-denis8
?>

Задан двумерный массив с из 4-х строк и 4-х столбцов (квадратная матрица составить программу подсчёта суммы всех отрицательных элементов и суммы элементов по главной диагонали. : 3

Информатика

Ответы

ag-modul
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(4,4,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  var sn:=a.ElementsByRow.Where(t->t<0).Sum;
  Writeln('Сумма отрицательных элементов равна ',sn);
  var sd:=0;
  for var i:=0 to a.RowCount-1 do sd+=a[i,i];
  Writeln('Сумма элементов на главной диагонали равна ',sd);
end.

Пример
*** Исходный массив ***
  55 -36  70  19
  79  14   5  -5
  79  -9 -62  20
 -71  69 -34  66

Сумма отрицательных элементов равна -217
Сумма элементов на главной диагонали равна 73
annanas08
If(i=j)
{
A[i][j]+=A[i][j]
}
А вообще в инете вбей,cyberforum, найдешь
Вячеславович-Дмитрий1694
Граф - множество вершин и ребер, соединяющих эти вершины.
Он несет информацию об элементах системы и связи между ними.
Элементы системы изображаются как вершины или узлы графа.
Отношения между ними изображаются как ребра или дуги графа.
Деревом называют ациклический (то есть между любыми вершинами есть только один путь), связный (то есть от любой вершины графа можно добраться в другую) граф.
Корень дерева - это вершина с нулевой степенью захода (то есть в нее не ведут другие ребра). Для неориентированного графа это просто выбранная нами вершина.
Ветви - это ребра дерева.
Листья дерева - это вершины с нулевой степенью исхода (то есть из них не выходят ребра), т.е. не имеющих поддеревьев.
Надеюсь объяснил доступно.
Yurevna419
вот такую херь я нарыл курсе "Компетенции преподавателя электронного обучения" "1. Насколько вас устроил уровень организации мероприятия? Устроил полностью. 2. Какие информационные блоки вы отметили бы особенно и почему? Зарубежный опыт организации ЭО, что это не дело рук одного преподавателя, а коллектива. 3. Какова практическая ценность полученных материалов? Метод знакомиться со студентами в ЭС, потому что не всегда хватает очных занятий для этого. 4. На какие проблемы стоит обратить внимание? Работа в группах при таком большом потоке слушателей сложна в организации, в результате идеи мы представляли, а обратной связи не было, поэтому это было больше развлечением, чем практически ценным. 5. Какие рекомендации и пожелания вы можете для нас оставить? Больше практики. И ИНЭО все таки закупить ПО для более качественного обеспечения работы преподавателя в ТПУ в ЭС, а не пользоваться бесплатными ресурсами интернета, накладывающими свои рекламные логотипы. ". А.В. Жаворонок, кафедра экономики, ассистент О курсе "Организация учебного процесса с использованием технологий электронного обучения по смешанной модели (на основе LMS Moodle и других инструментов и сервисов ЭО за совместную работу, в целом все было замечательно. По курсу Разработка электронного курса по дисциплине на базе LMS Moodle с использованием инструментов и сервисов электронного обучения все отлично, к координаторам можно было всегда подойти и уточнить возникшие во По второму курсу Организация учебного процесса с использованием технологий электронного обучения по смешанной модели (на основе LMS Moodle и других инструментов и сервисов ЭО) я столкнулась со странной стратегией - время вебинаров не совпадало с заявленным и начало вебинара не было прописано в календаре (было бы лучше указывать точное время вебинара в календаре, т.к. календарем пользуются) (и да, только первое началось в указанное время). Мне очень было жаль технарей, т.к. не все термины из педагогики/сетодики им были знакомы. Здесь нужно составить хотя бы мини-глоссарий с наиболее употребляемыми терминами из методики и педагогики (которые позднее будут использованы в презентациях). Эти моменты действительно были самыми запоминающимися, опять-таки, повторюсь, но организаторы курса практически сразу реагировали на сообщения, отвечали и оставляли комментарии по работе. (мне конечно же хотелось получать ответ сразу после моего выложенного, но здесь была своя система, вероятно, по причине большого количества курсантов). Мне кажется, был некоторый перегруз теорией и заданиями, особенно последние два - они были слишком энергозатратными. (Вот, цель 3 лекции не ясна - во к лекции нет, видимо, только лишь для ознакомления)... Данный курс повышения квалификации и нужный, и полезный, задания, необходимые для выполнения, заставляют мозг работать в усиленном режиме большое преподавателям, которые с нами работали и до нас пытались донести все значимое!" Н.В. Аксенова, кафедра иностранных языков института кибернетики, старший преподаватель .

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задан двумерный массив с из 4-х строк и 4-х столбцов (квадратная матрица составить программу подсчёта суммы всех отрицательных элементов и суммы элементов по главной диагонали. : 3
Ваше имя (никнейм)*
Email*
Комментарий*