Koshovkina1721
?>

Массив а вводится с клавиатуры. найти сумму его элементов. размер произвольный. составить программу.

Информатика

Ответы

izumrud153
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln(ReadSeqInteger(ReadInteger).Sum)
end.

Пример
7
-5 13 19 0 -3 21 11
56
Ioanova Korneeva1093
Program Ok;
const n = 10;
var
A:array[1..n] of integer;
i,sum:integer;
begin
sum:=0;
for i:=1 to n do
begin
read(A[i]);
sum:=sum+A[i];
end;
writeln(sum);
end.
ПогальниковАлёна589
1. Треугольник будет существовать если будут выполнятся одновременно три неравенства:
x + y > z
x + z > y
y + z > x

Программа:

var x, y, z: real;
begin
  writeln('Введите стороны треугольника x, y, z: ');
  read(x, y, z);
  if (x + y > z) and (x + z > y) and (y + z > x) 
  then writeln('Треугольник существует')
  else writeln('Треугольник не существует');
end.

2. Думаю, здесь излишни объяснения.

Программа:

var x, y, z: real;
begin
  writeln('Введите три числа: ');
  read(x, y, z);
  writeln('В интервале (1; 3) лежат числа: ');
  if (x > 1) and (x < 3) then writeln(x);
  if (y > 1) and (y < 3) then writeln(y);
  if (z > 1) and (z < 3) then writeln(z);
end.

Блок-схемы в приложении:
Составить блок-схему и написать программу на языке pascalabc.net. 1. даны действительные положительн
Составить блок-схему и написать программу на языке pascalabc.net. 1. даны действительные положительн
Dmitrii sergei463

Сам по себе процесс моделирования в полной мере не формализован, большая роль в этом принадлежит опыту инженера. Но, тем не менее, рассматриваемый в теме процесс создания модели в виде шести этапов может стать основой для начинающих и с накоплением опыта может быть индивидуализирован.

Математическая модель, являясь абстрактным образом моделируемого объекта или процесса, не может быть его полным аналогом. Достаточно сходства в тех элементах, которые определяют цель исследования. Для качественной оценки сходства вводится понятие адекватности модели объекту и, в связи с этим, раскрываются понятия изоморфизма и изофункционализма. Формальных приемов, позволяющих автоматически, "бездумно", создавать адекватные математические модели, нет. Окончательное суждение об адекватности модели дает практика, то есть сопоставление модели с действующим объектом. И, тем не менее, усвоение всех последующих тем пособия позволит инженеру справляться с проблемой обеспечения адекватности моделей.

Завершается тема изложением требований к моделям, которые были сформулированы Р. Шенноном на заре компьютерного моделирования тридцать лет назад в книге "Имитационное моделирование систем - искусство и наука". Актуальность этих требований сохраняется и в настоящее время.

Этапы:

Первый этап – постановка задачи. Прежде всего следует уяснить цель моделирования. Исходя из цели моделирования, определяется вид и форма представления информационной модели, а также степень детализации и формализации модели. В соответствии с целью моделирования заранее определяются границы применимости  создаваемой модели. На этом этапе также необходимо выбрать инструментарий, который будет использоваться при моделировании (например, компьютерную программу).  

Второй этап – собственно моделирование, построение модели. На этом этапе важно правильно выявить составляющие систему объекты, их свойства и взаимоотношения и представить всю эту информацию в уже выбранной форме. Создаваемую модель необходимо периодически подвергать критическому анализу, чтобы своевременно выявлять избыточность, противоречивость и несоответствие целям моделирования.

Третий этап – оценка качества модели, заключающаяся в проверке соответствия модели целям моделирования. Такая проверка может производиться путем логических рассуждений, а также экспериментов, в том числе и компьютерных. При этом могут быть уточнены границы применимости модели. В случае выявления несоответствия модели целям моделирования она подлежит частичной или полной переделке.

Четвертый этап – эксплуатация модели, ее применение для решения практических задач в соответствии с целями моделирования.

Пятый этап – анализ полученных результатов и корректировка исследуемой модели.

формализация:представление какой-либо содержательной области (рассуждений, доказательств, процедур классификации, поиска информации, научных теорий) в виде формальной системы или исчисления.

Может ли объект иметь несколько моделей: ну да. Обьект может иметь сколь угодно моделей.

Пример:

Часовой мехнанизм.

Может иметь:

-3D модель

-математическую модель

-физическую модель

и др.

Могут ли разные объекты описываться одной и той же моделью:Разные объекты могут описываться одной и той же моделью. Например, для описания движения планет, движения автомобиля или движения мяча в определенных условиях (размеры объекта гораздо меньше его перемещений) можно использовать одну и ту же модель движения материальной точки.

ПРограммы: Blender, 3d Max, Sculpt. и т.д

Если хоть не жалуйтесь

мне 13

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Массив а вводится с клавиатуры. найти сумму его элементов. размер произвольный. составить программу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lena260980
vera-classic75
bezpalova2013
snab54
Chopper-hinter25
tsatskina857
edvard-b
orinvarostov
svetlanam81
mekap22044
admiralbany
myataplatinumb348
metelkin7338
liza04521160