laktionova-natal
?>

напишите программу на паскале! разработайте программу, которая строит таблицу значений функции y=(ln x)/tg x при заданных диапазоне [a, b] изменения x и шаге h. если значение функции в очередной точке не существует, то в соответствующей строке таблицы выведите сообщение «значение не существует».

Информатика

Ответы

mikchaylovaalex
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,h):=ReadReal3('Введите границы и шаг табуляции:');
  if a>b then Swap(a,b); // если перепутали границы
  var x:=a;
  while x<=b+h/2 do begin
    Write(x:10:5);
    var y:=Ln(x)/Tan(x);
    if real.IsNaN(y) or real.IsInfinity(y) then
      Writeln('       значение не существует')
    else Writeln(y:15:5);
    x+=h
    end
end.

Примеры
Введите границы и шаг табуляции: -5 5 1
  -5.00000       значение не существует
  -4.00000       значение не существует
  -3.00000       значение не существует
  -2.00000       значение не существует
  -1.00000       значение не существует
   0.00000       значение не существует
   1.00000        0.00000
   2.00000       -0.31722
   3.00000       -7.70704
   4.00000        1.19733
   5.00000       -0.47609

Введите границы и шаг табуляции: -1 1 0.2
  -1.00000       значение не существует
  -0.80000       значение не существует
  -0.60000       значение не существует
  -0.40000       значение не существует
  -0.20000       значение не существует
   0.00000       значение не существует
   0.20000       -7.93961
   0.40000       -2.16723
   0.60000       -0.74667
   0.80000       -0.21672
   1.00000        0.00000
rusart3

ответ: поменяешь на украинский язык 'названия предметов'

from random import randint

i = ['камень', 'ножницы', 'бумага']

while True:

   hod = input('Введите ваш код: ')

   hodk = randint(1, 3)

   if hod == i[hodk-1]:

       print('Ничья')

       print('Мой ход был', i[hodk-1])

   if i[hodk-1] == 'камень' and hod == 'бумага':

       print('Вы выиграли')

       print('Мой ход был', i[hodk - 1])

   elif i[hodk-1] == 'бумага' and hod == 'камень':

       print('Вы проиграли')

       print('Мой ход был', i[hodk - 1])

   if i[hodk-1] == 'ножницы' and hod == 'камень':

       print('Вы выиграли')

       print('Мой ход был', i[hodk - 1])

   elif i[hodk-1] == 'камень' and hod == 'ножницы':

       print('Вы проиграли')

       print('Мой ход был', i[hodk - 1])

   if i[hodk-1] == 'бумага' and hod == 'ножницы':

       print('Вы выиграли')

       print('Мой ход был', i[hodk - 1])

   elif i[hodk-1] == 'ножницы' and hod == 'бумага':

       print('Вы проиграли')

       print('Мой ход был', i[hodk - 1])

Norov

Компью́тер (англ. computer, МФА: [kəmˈpjuː.tə(ɹ)][1] — «вычислитель», от лат. computare — считать, вычислять[2]) — устройство или система автоматически выполнять заданную, изменяемую последовательность операций. Это чаще всего операции численных расчётов и манипулирования данными, однако сюда относятся и операции ввода-вывода. Описание последовательности операций называется программой[3].

Компьютерная система — любое устройство или группа взаимосвязанных или смежных устройств, одно или более из которых, действуя в соответствии с программой, осуществляет автоматизированную обработку данных[4].

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

напишите программу на паскале! разработайте программу, которая строит таблицу значений функции y=(ln x)/tg x при заданных диапазоне [a, b] изменения x и шаге h. если значение функции в очередной точке не существует, то в соответствующей строке таблицы выведите сообщение «значение не существует».
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

martinson1136
Роман_Гречина
Marina658
Yevgenevich775
Герасимова107
heodbxbbshe
Анатольевич
mausgaly
АртакСергеевич1723
mokeevahelena
len22
Банова_Елена431
anazarov80
zdl2008
perfectorg