Код ниже.
Объяснение:
Для подсчета длины отрезка, нужно знать 4 координаты. А(x;y) и B(x;y).
По формуле L = √(X²+Y²) = √ ((Xb-Xa)²+(Yb-Ya)²) мы можем подсчитать длину любого отрезка по известным координатам.
Код:
import math
a = input('Входные данные: ')
s = a.split(' ')
print("Выходные данные: ",math.sqrt(math.pow(float(s[2]) - float(s[0]),2)+math.pow(float(s[3]) - float(s[1]),2)))
Импортируем модуль math для упрощения жизни и себе и людям. Задаем переменную к которой присваиваем значения введенные с клавиатуры в таком формате (Xa(пробел)Ya(пробел)Xb(пробел)Yb(пробел)) например у нас есть 2 точки А с координатами (1;2) и B(3;4) тогда ввод будет такой: "1 2 3 4"
Дальше преобразуем строку в список с разделителем "пробел"
И дальше идет формула, которую записал выше. Float вместо Int потому что значения могут быть с плавающей точкой.
Поделитесь своими знаниями, ответьте на вопрос:
// Внимание! Если программа не работает, обновите версию!
begin
var (x,y,z):=ReadReal3('Введите через пробел три числа:');
if (x+y>z) and (x+z>y) and (y+z>x) then Writeln('Треугольник существует')
else Writeln('Треугольник не существует')
end.
Примеры
Введите через пробел три числа: 2.34 5.18 9
Треугольник не существует
Введите через пробел три числа: 3 4 5
Треугольник существует