stendpost
?>

75 ! напишите программу, которая в списке из десяти случайных целочисленных элементов из диапазона от 0 до 100 находит максимальный чётный и минимальный нечётный элементы.

Информатика

Ответы

Yurevna
PascalABC.NET
Версия 3.3. сборка 1583 (25.11.2017)

var a:array[1..10] of integer;
begin
 var max:=2;
 var min:=101;
 for var i:=1 to 10 do
 begin
  a[i]:=random(0,100);
  write(a[i],' ');
  if (a[i] mod 2=0) and (a[i]>max)
    then max:=a[i];
   if (a[i] mod 2=1) and (a[i]<min)
    then min:=a[i];
 end;
  writeln;
  writeln('Минимальный нечетный елемент - ',min);
  writeln('Максимальный четный елемент - ',max);
readln;
end.
axo-geo
//Pascal
var
  A: array [1..10] of byte;
  i, min, max: byte;
begin
randomize;
min := 101; max := 0;
  for i := 1 to 10 do
  begin
    A[i] := random(101);
    if ((A[i] < min) and (A[i] mod 2 <> 0)) then min := A[i];
    if ((A[i] > max) and (A[i] mod 2 = 0)) then max := A[i]; 
    write(A[i], ' '); 
  end;
writeln;
writeln('Максимальный четный = ', max); 
writeln('Минимальный нечетный = ', min);    
readln;
end.

75 ! напишите программу, которая в списке из десяти случайных целочисленных элементов из диапазона о
krasilnikov74
Program Ves;
Var a1,a2,a3,a4,t1,t2,t3,p,d,vp,b: Integer;
begin 
writeln ('программа вычисляет норму для данного ученика');
writeln ('введи массу учебника 1');readln (a1);
writeln ('введи массу учебника 2');readln (a2);
writeln ('введи массу учебника 3');readln (a3);
writeln ('введи массу тетради 1');readln (t1);
writeln ('введи массу тетради 2');readln (t2);
writeln ('введи массу тетради 3');readln (t3);
writeln ('введи массу пенала');readln (p);
writeln ('введи массу дневника');readln (d);
writeln ('введи массу портфеля');readln(vp);
b:=a1+a2+a3+a4+t1+t2+t3+p+d+vp;writeln ('общая масса портфеля= ' b);
if (b<=5) then writeln ('норма') else writeln ('ненорма');
readln;
end.
mikhail
Из условия Фано следует, что в префиксном неравномерном двоичном коде, предусматривающем однозначное декодирование, ни одно кодовое слово не может быть началом другого. 

Таким образом, оставшиеся три кода не могут быть началом кода буквы Б, и началами кодов друг друга.

То есть коды 0 и 00 отпадают сразу, т.к. это начала буквы Б.

Если предположить, что один из кодов равен 1, и что нам нужны кратчайшие коды, значит оставшиеся коды могут быть только 01 и 011.

Если предположить, что коды двузначны, тогда кодами могут быть 01, 10 и 11.

В первом случае суммарная длина кодов равна 1+2+3+3 = 9, во втором случае - 2+2+2+3 = 9.

Оба варианта подходят, кратчайшая суммарная длина - 9

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

75 ! напишите программу, которая в списке из десяти случайных целочисленных элементов из диапазона от 0 до 100 находит максимальный чётный и минимальный нечётный элементы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

VdoffOlga
kapitan19
mileva84
Korinchan390
aregaa
rusinfopro
Olgachalova111
Aleksandrovich1415
alexkortyukov
MikhailovichKrizhnaya578
ravshandzon3019835681
sov0606332
gbg231940
vypolga1347
bksenia9775