dannytr
?>

Впаскале. дано трехзначное число. напишите программу определения, является ли оно палиндромом, т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево. требуется вывести «yes», если число является палиндромом, и «no» в противном случае. примеры: входные данные данные 101 142

Информатика

Ответы

Коробкова1437
Var  a: integer;begin  readln (a);    if (a mod 10 = a div 100) then write ('YES')  else write ('NO');end.  
oduvanalex
Если не соблюдать технику безопасности может возникнуть замыкание и пожар или можно что-либо сломать себе, повредить технику. Основными являются - не вставать по время работы за компьютером, а так же не есть за компьютерным столом/не приносить еду в класс. Неправильная посадка может привести к искривлению и другим многочисленным проблемам, если при неправильной посадке зацепить какой-либо провод можно нанести вред технике и себе. Рекомендаций не знаю сорь, но можешь написать что нельзя есть за столом, раскачиваться на стуле и.т.д
mupmalino2653
20:02-4:11=15:51
ответ: 4 ч 11 мин.

Более подробно: 20:02 - если не учитывать, что в часе 60 минут, то предыдущее "счастливое" время - 19:91, но это не подходит, т.к. часы не могут показывать столько, дальше аналогично:
18:81 - не подходит;
17:71 - не подходит;
16:61 - не подходит;
15:51 - подходит, значит, это - предыдущее "счастливое" время.
Чтобы найти, сколько времени с 15:51 до 20:02, то есть найти, насколько 20:02 больше, чем 15:51, нужно из большего отнять меньшее: 20:02-15:51=4:11, то есть 4 часа 11 минут.
ответ: 4 ч 11 мин.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Впаскале. дано трехзначное число. напишите программу определения, является ли оно палиндромом, т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево. требуется вывести «yes», если число является палиндромом, и «no» в противном случае. примеры: входные данные данные 101 142
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

melissa-80
bulin2001
Тимур Андраниковна634
okovyrova1
elyashatdinova
sergeystepanov231
tatiana2676
Мартынова1638
zhannasokortova
andrey4work918
okutihamv
Элизбарян
vitbond12
Ohokio198336
siren89