Для определения чётности или нечётности числа используется следующее условие:
if S%2==0:
print('Число чётное')
else:
print('Число нечётное')
Разберём условие S%2==0:
Знак % находит остаток от деления чисел, при этом целую часть он не учитывает. Так, например, 5%2 будет равняться 1
Ещё несколько примеров нахождения остатка:
15%4=3
10%7=3
6%2=0
Чётное число это число, которое делится на 2 без остатка, именно это мы и проверяем: если число делится на 2 без остатка (т.е., остаток 0), то оно чётное, а если же нет, то оно нечётное.
Наша i изначально равна 1, условие звучит как:
Пока i<=12, то...
Обратим внимание, что внутри цикла к нашей i постоянно прибавляется 4.
Чтобы наше условие i<=12 нарушилось, к нашей 1 надо 3 раза добавить число 4, таким образом мы понимаем, что наш цикл выполнится 3 раза.
Запускаем цикл первый раз, до его старта i=1, s=0
s:=s+i - на данный момент s=0, i=1, их и подставляем:
s:=0+1 = 1 - Новое значение s, старое значение мы теряем
i:=i+4 -на данный момент i=1, его и подставляем
i:=1+4=5 - старое значение (1) мы теряем
Завершился первый цикл. Проверяем условие запуска второго цикла: i<=12
5<=12 ? Да. Запускаем цикл:
s:=s+i
s:=1+5=6
i:=i+4
i:=5+4=9
Завершилось второе выполнение цикла.
i<=12?
9<=12? Да. Запускаем цикл:
s:=s+i
s:=6+9=15
i:=i+4
i:=9+4=13
Завершилось третье выполнение цикла.
i<=12?
13<=12? Нет! Цикл не запускается, программа продолжает своё выполнение.
В самом конце программы у нас выводится значение s. Её актуальное значение: 15, что и будет являться ответом.
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу на паскаль ввести с клавиатуры название фигуры, которую надо построить: круг или треугольник. нарисовать соответствующую фигуру синего цвета на белом фоне. использовать оператор условия.
var s:string;
begin
writeln('Введите название фигуры (круг или треугольник):');
readln(s);
setwindowsize (640,480);
setwindowtitle (s);
setpencolor (clBlue);
setpenwidth (4);
if s='круг' then
circle(300,200,120)
else begin
Line(300,50,30,400);
Line(30,400,570,400);
Line(570,400,300,50);
end;
end.