kuz-vlad21
?>

Впростой понятной форме. напишите программу, которая заполняет массив случайными числами в диапазоне [a, b] и сортирует его “домиком” – до половины в порядке возрастания, затем – в порядке убывания. количество элементов в массиве может быть любое! с объяснениями и откуда что взялось?

Информатика

Ответы

ilds88
Var
  A: array [1..255] of integer;
  N, i, j, k, min, max: integer;
begin
  //Ввод количества элементов в массиве
  write('Введите четное количество элементов: ');
  readln(N);
 
  //Ввод двух чисел для диапазона случайных чисел
  write('Введите диапазон случайных чисел: ');
  readln(min, max);
 
  //Инициализация датчика случайных чисел.
  //(в PascalABC.NET необязательно)
  randomize;
 
  //Заполнение массива
  for i := 1 to N do
  begin
    A[i] := random(max-min+1)+min;
    write(A[i]:4);
  end;
  writeln;
 
  //Сортировка первой половины по убыванию
  for i := 1 to ((N div 2)-1) do
    for j := 1 to (N div 2)-i do
      if A[j] > A[j+1] then
      begin
        k := A[j];
        A[j] := A[j+1];
        A[j+1] := k;
       end;
       
  //Сортировка второй половины по убыванию
  for i:=(N div 2) to N-1 do
    for j:=i+1 to N do
      if A[i]<A[j] then
      begin
        k:=a[i];
        A[i]:=A[j];
        A[j]:=k;
      end;

  //Вывод массива
  for i := 1 to N do write(A[i]:4);
  writeln;
  readln;
end.
dg9792794674

Задание 1: 4132

4 Экзамен | ЕГЭ | Информатика | Литература

1 Экзамен | ЕГЭ | Информатика

3 Экзамен | ЕГЭ

2 Экзамен & ЕГЭ & Информатика

Задание 2: 3124

3 рыбки

1 рыбки & аквариум

2 рыбки & аквариум & гуппи

4 рыбки & аквариум & гуппи & купить

Задание 3: 3421

3 Сок | Нектар

4 Сок

2 Сок & Апельсин

1 Сок & Апельсин & Яблоко

Задание 4: 2134

2 волейбол | баскетбол | подача | блок

1 волейбол | баскетбол | подача

3 волейбол | баскетбол

4 волейбол & баскетбол & подача

Задание 5: 2341

2 алгоритм & сжатие & графика & архиватор

3 алгоритм & сжатие

4 алгоритм | (сжатие & графика)

1 сжатие | графика | алгоритм

Задание 6: 1423

1 (Автомобили – Ford) & новые

4 Автомобили – Ford

2 Автомобили

3 Автомобили | Ford

Задание 7: 3124

3 отдых & Сочи & Адлер

1 отдых & (Сочи | Адлер)

2 отдых & (море | Сочи | Адлер)

4 отдых | Сочи | Адлер

Задание 8: 4123

4 строительный & стоимость & купить & купить

1 строительный & стоимость & купить

2 строительный | материал | купить

3 строительный | материал | стоимость | купить

Задание 9: 5000

Новосибирск 3300

Красноярск 2200

Новосибирск & Красноярск 500

Новосибирск | Красноярск 5000

Задание 10:

Атос & Портос 335

Атос & Арамис 225

Атос & Портос & Арамис 120

Атос & (Портос | Арамис) 440

Графические подтверждения:


В таблице приведены запросы к поисковому серверу. Расположите номера запросов в порядке убывания кол
В таблице приведены запросы к поисковому серверу. Расположите номера запросов в порядке убывания кол
Геннадьевна Вета560

Монито́р — устройство, предназначенное для воспроизведения видеосигнала и визуального отображения информации, полученной от компьютера. Принципиальное отличие от телевизора заключается в отсутствии встроенного тюнера, предназначенного для приёма высокочастотных сигналов эфирного (наземного) телевещания. Кроме того, в большинстве мониторов отсутствует звуковоспроизводящий тракт и громкоговорители.

Современный монитор состоит из экрана (дисплея), блока питания, плат управления и корпуса. Информация для отображения на мониторе поступает с электронного устройства, формирующего видеосигнал (в компьютере — видеокарта или графическое ядро процессора).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Впростой понятной форме. напишите программу, которая заполняет массив случайными числами в диапазоне [a, b] и сортирует его “домиком” – до половины в порядке возрастания, затем – в порядке убывания. количество элементов в массиве может быть любое! с объяснениями и откуда что взялось?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

veniaminsem
axo4937
olgakuz00261
Наталья_Васищев
pokrov777krest
master-lamaster
МуратМарина1140
motor2218
Sadovskaya425
zapros
Рудаков Бахтовар
kozhevniks
kisa-luba
Valerevna-Vardan
Беспалова