taksa6444
?>

Написать программу, которая определяет, каким днем (рабочий день, суббота, воскресенье) является введенный номер дня недели. в теранарном операторе, как делать?

Информатика

Ответы

krispel9
Не "теранарный", а тернарный оператор.
Есть во многих языках программирования, зря не указали, какой Вам надо.

// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('День недели (1- Пн, 2- Вт, ... 7- Вс:');
  Writeln(n<6?'Рабочий день':n=6?'Суббота':'Воскресенье')
end.

Примеры (предполагается без проверки корректность ввода)
День недели (1- Пн, 2- Вт, ... 7- Вс: 4
Рабочий день

День недели (1- Пн, 2- Вт, ... 7- Вс: 6
Суббота

День недели (1- Пн, 2- Вт, ... 7- Вс: 7
Воскресенье
Mikhailova

задача1 чтобы подсчитать общее количество равновероятных событий (количество подъездов) воспользуемся формулой N=2^i вместо i подставим 2 и получим N=2^2, т.е. 4

ответ: в доме 4 подъезда

задача2  чтобы подсчитать общее количество равновероятных событий (количество ящиков) воспользуемся формулой N=2^i вместо i подставим 3 и получим N=2^3, т.е. 8

ответ: на склад поступило 8 ящиков

задача4 в тексте 61 символ. при использовании 256 -символьного алфавита, вес 1 символа составляет 8 бит

умножим 8 на 61 получим 488 бит

задача5

запишем условие: страниц=3, строк=60, символы=65, I=8775 байт, N=?

решение: выразим информационный объем текста в битах

I=8775*8=70200 бит

узнаем сколько всего символов в тексте

К=3*60*65=11700

теперь вычислим вес одного символа

i=I/K=70200/11700=6 бит

применим теперь формулу мощности алфавита:

N=2^i, N=2^6, N=64



proporcia46

"Я самый главный!"- заявил монитор, на мне возникает информация и изображения.

"Нет, я самая главная,- сказала клавиатура, без меня никак, не сможешь ничего оттреадактировать,вбить информацию в память, общаться - да вообще ничего!"

Но память возразила : " Ээх вы, я тут главнее всех, как вы без меня! Ничего не сохранишь, не запомнишь, да в общем без меня очень сложно что-то представить!"

"Да вы что? - начал возмущаться процессор, - Главных не должно быть, мы все представляем собой одно целое!" Так они и воссоединились и представляют собой одну частичку главного . 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая определяет, каким днем (рабочий день, суббота, воскресенье) является введенный номер дня недели. в теранарном операторе, как делать?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

teashop
abadaeva
orion-inginiring7807
vik-2202
tarhan1221
ГегамБукреев830
Varezka86179
gen218
Kelena190533
Vos-sv
gorod7
Анатольевич
Александр734
goldenshtein33333
laplena1982750