chizhenkovd9
?>

Практическое №7 тема: знакомство с языком паскаль. 1. а) набрать в редакторе системы турбо-паскаль следующую программу: program my; var a, b, c, s: integer; begin readln(a); readln(b); readln(c); s: =a*b*c; writeln(s) end. б) откомпилировать набранную программу и исправить ошибки. в) запустить данную программу на выполнение и проверить правильность её работы для чисел 2, 4 и 6. г) запустить данную программу на выполнение и проверить правильность её работы для чисел 1, 0 и -1. д) запустить данную программу на выполнение и проверить правильность её работы для чисел -2, 3 и 10. 2. написать программу, которая присваивает целой переменной a значение 10 и выводит это значение на экран. 3. написать программу, которая запрашивает ввод целого числа в переменную b и выводит это число на экран. проверить правильность работы программы на числах 1, -5, 256, 10455. 4. написать программу, которая запрашивает ввод вещественного числа в перемен-ную c, умножает это число на 2 и выводит результат на экран. проверить правильность работы программы на числах 2.5, -7.33, 0, 782.234. 5. написать программу для ввода значения величины x целого типа, присваивания величине y действительного типа значения 5.5, вычисления значения величины z = x - y и вывода значения величины z. протестировать программу для x=5.5, x=0, x=-10.2

Информатика

Ответы

ruslan
На первое задание ответ письменно не дашь так что сорян ...... могу сказать что нажимаете F9 и вводите значение которые вам нужны
Практическое №7 тема: знакомство с языком паскаль. 1. а) набрать в редакторе системы турбо-паскаль с
natalili32

Program a1;
Uses crt;
const n=8;
Var a:array[1..n] of integer;
ch,s:integer;
sr:real;
i:byte;
Begin
Writeln('Массив');
For i:=1 to n do
begin
a[i]:=random(101)-50;
writeln(a[i]);
end;
For i:=1 to n do
s:=s+a[i];
sr:=s/n;
For i:=1 to n do
if a[i] mod 2 = 0 then ch:=ch+1;
s:=0;
For i:=1 to n do
if i mod 2 <> 0 then s:=s+a[i];
Writeln('ответы');
Writeln('1) Среднее значение элементов массива = ', sr);
Writeln('2) Количество чётных элементов = ', ch);
Writeln('3) Сумма элементов массива с нечётными номерами = ', s);
End.

Оксана Анна

1)

const NN=50;
var
a:array [1..NN] of integer;
i,n:integer;
s:real;
begin
  write('Введите количество элементов массива: ');
  readln(n);
  s:=0;
  for i:= 1 to n do
  begin
    readln(a[i]);
    s:=s+a[i];
  end;
 writeln('Среднее арифметическое массива = ',s/n)
 end.

 

2)

const NN=50;
var
a:array [1..NN] of integer;
i,n:integer;
s:real;
begin
  write('Введите количество элементов массива: ');
  readln(n);
  s:=0;
  for i:= 1 to n do
  begin
    readln(a[i]);
    if a[i] mod 2 =0 then s:=s+1;
  end;
 writeln('Количество четных элементов = ',s)
 end.

 

3)

const NN=50;
var
a:array [1..NN] of integer;
i,n:integer;
s:real;
begin
  write('Введите количество элементов массива: ');
  readln(n);
  s:=0;
  for i:= 1 to n do
  begin
    readln(a[i]);
    if i mod 2 =1 then s:=s+a[i];
  end;
 writeln('Cумма элементов с нечетными номерами = ',s)
 end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Практическое №7 тема: знакомство с языком паскаль. 1. а) набрать в редакторе системы турбо-паскаль следующую программу: program my; var a, b, c, s: integer; begin readln(a); readln(b); readln(c); s: =a*b*c; writeln(s) end. б) откомпилировать набранную программу и исправить ошибки. в) запустить данную программу на выполнение и проверить правильность её работы для чисел 2, 4 и 6. г) запустить данную программу на выполнение и проверить правильность её работы для чисел 1, 0 и -1. д) запустить данную программу на выполнение и проверить правильность её работы для чисел -2, 3 и 10. 2. написать программу, которая присваивает целой переменной a значение 10 и выводит это значение на экран. 3. написать программу, которая запрашивает ввод целого числа в переменную b и выводит это число на экран. проверить правильность работы программы на числах 1, -5, 256, 10455. 4. написать программу, которая запрашивает ввод вещественного числа в перемен-ную c, умножает это число на 2 и выводит результат на экран. проверить правильность работы программы на числах 2.5, -7.33, 0, 782.234. 5. написать программу для ввода значения величины x целого типа, присваивания величине y действительного типа значения 5.5, вычисления значения величины z = x - y и вывода значения величины z. протестировать программу для x=5.5, x=0, x=-10.2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

cat2572066
ИгоревичАндрей
Nugamanova-Tatyana840
Olga-Lev1160
Boss5519
info32
thedoomsdatdcs36
snow8646
iamhrusha
office3
ZharikovZalina
Макаров1887
stusha78938
fiorire731
dushechkin2