hvostna23
?>

1)дан одномерный массив. положительные элементы уменьшить в два раза, отрицательные заменить их индексами. 2)дан одномерный массив. найти произведение элементов массива. паскаль написать программу если можно блок схему

Информатика

Ответы

natalyaSvetlana
//Pascal
//Массивы размеров 10 элементов заполняются случайными числами от -10 до 10

//1
var
  A: array[1..10] of real;
  i: byte;
begin
randomize;
writeln('Исходный массив.');
for i := 1 to 10 do
begin
  A[i] := random(21)-10;
  write(A[i]:5);
end;
writeln;
writeln('Измененный массив.');
for i := 1 to 10 do
begin
  if A[i] > 0 then A[i] := A[i] / 2
  else A[i] := i;
  write(A[i]:5);
end;
writeln;
end.

//2
var
  A: array[1..10] of integer;
  i: byte;
  mult: longint;
begin
mult := 1;
randomize;
writeln('Исходный массив.');
for i := 1 to 10 do
begin
  A[i] := random(21)-10;
  mult := mult * A[i];
  write(A[i]:5);
end;
writeln;
writeln('Произведение элементов массива = ', mult);
end.
ЮлияДаниил520

1) для перевода из 10-й в двоичную 2-ую систему счисления нужно число в десятичной системе разделить на 2 и записать остаток , затем тоже самое сделать с целой часть и повторять пока не останется только 1 или 0. конечное числом будут остатки записанные в обратном порядке.

1450/ 2 = 725 остаток 0

725 / 2 = 362 остаток 1

362 / 2 = 181 остаток 0

181 / 2 = 90 остаток 1

90 / 2 = 45 остаток 0

45/ 2 = 22 остаток1

22/2 = 11 остаток 0

11/ 2 = 5 остаток 1

5 / 2 = 2 остаток 1

2 / 2 = 1 остаток 0

1 / 2 = 0 остаток 1

 

результат: 10110101010

 

в 2-х байтовой ячеке всего 16 разрядов, а в наше числе 11 , значит спереди нужно дописать 5 нулей и получим нужное представление

0000010110101010

 

2)

для перевода в 16 систему нужно сначало перевести в 2-ю систему счисления, потом записать обратный код, почитать дополнительный и тогда перевести в 16-ю

вот 1450 в 2-й системе

0000010110101010

обратный код это код в котором все 0 заменены на 1, а 1 на 0

1111101001010101

чтобы получит дополнительный код нужно прибавить 1

1111101001010110

теперь смотрим по 4 разряда и заменяем 1 символом в 16 системе счисления

1111 = f

1010 = a

0101 = 5

0110 = 6

искомое число fa56

3)

  для перевода из 16 в 2 систему счисления нужно каждую цифру числа умножит на 16 в степень равным номеру цифры(справа на лево, отсчет с 0)

f67d(в 16 системе счисления) = 15 * 16 ^3 + 6 * 16 ^2 + 7 * 16^1 + 13 * 16 ^0 = 61440 + 1536 + 112 + 13 = 63101(в 10 системе счисления)

korotinadasha07

С давних пор люди сталкивались с необходимостью определять расстояния, длины предметов, время, площади, объемы и т. д.

Измерения нужны были и в строительстве, и в торговле, и в астрономии, фактически в любой сфере жизни. Очень большая точность измерений нужна была при строительстве египетских пирамид.

Рис. 0

Значение измерений возрастало по мере развития общества и, в частности, по мере развития науки. А чтобы измерять, необходимо было придумать единицы различных физических величин. Вспомним, как написано в учебнике: “Измерить какую-нибудь величину – это значит сравнить ее с однородной величиной, принятой за единицу этой величины”.

Целью моей работы было выяснить: какие существовали и существуют сейчас единицы длины и массы, каково их происхождение?

Вершок, локоть и другие единицы...

Измеряй все доступное измерению и делай не доступное измерению доступным”.

Г.Галилей

Самыми древними единицами были субъективные единицы. Так, например, моряки измеряли путь трубками, т. е. расстоянием, которое проходит судно за время, пока моряк выкурит трубку. В Испании похожей единицей была сигара, в Японии – лошадиный башмак, т. е. путь, который проходила лошадь, пока не износится привязанная к ее копытам соломенная подошва, заменявшая подкову.

В программе Олимпийских игр Древней Эллады был бег на стадию. Установлено, что греческая стадия (или стадий) это длина стадиона в Олимпии – 192,27 м. Стадий равняется расстоянию, которое проходит человек спокойным шагом за время от появления первого луча солнца, при его восходе, до момента, когда диск солнца целиком окажется над горизонтом. Это время приблизительно равно двум минутам ...

Стадий, как единица измерения расстояний, был и у римлян (185 см), и у вавилонян (около 195 см), и у египтян (195 см).

В Сибири в стародавние времена употреблялась мера расстояний – бука. Это расстояние, на котором человек перестает видеть раздельно рога быка.

У многих народов для определения расстояния использовалась единица длины стрела – дальность полета стрелы. Наши выражения “не подпускать на ружейный выстрел”, позднее “на пушечный выстрел” – напоминают о подобных единицах длины.

Древние римляне расстояния измеряли шагами или двойными шагами (шаг левой ногой, шаг правой). Тысяча двойных шагов составляла милю (лат. “милле” – тысяча).

Длину веревки или ткани неудобно измерять шагами или стадиями. Для этого оказались пригодными встречающиеся у многих народов единицы, отождествляемые с названиями частей человеческого тела. Локоть – расстояние от конца пальцев до локтевого сустава.

     

Рис. 1                                  Рис. 2

Мерой длины для тканей, веревок и т.п. наматывающихся материалов у многих народов был двойной локоть. Этой мерой мы и сейчас пользуемся для приблизительной оценки длины...

На Руси долгое время в качестве единицы длины использовали аршин (примерно 71 см). Эта мера возникла при торговле с восточными странами (перс, “арш” – локоть). Многочисленные выражения: “Словно аршин проглотил”, “Мерить на свой аршин” и другие – свидетельствуют о ее распространении.

Для измерения меньших длин применяли пядь – расстояние между концами расставленных большого и указательного пальцев.

Рис. 3

Пядь или, как ее еще называли, четверть (18 см) составляла 1 / 4 аршина, а 1/ 16 аршина равнялся вершок (4,4 см).

Очень распространенной единицей длины была сажень. Впервые упоминание о ней встречается в XI в. С 1554 г. сажень устанавливают равной 3 аршинам (2,13 м) и она получает название царской (или орленой, печатной) в отличие от произвольных – маховой и косой. Маховая сажень – размах рук – равна примерно 2,5 аршинам. Рыбак, который показывает, какую большую рыбу он упустил, демонстрирует нам маховую.

Рис. 4

Косая сажень – расстояние от конца вытянутой вверх правой руки до носка левой ноги, она примерно равна 3,25 аршинам.

Рис. 5

Вспомним, как в сказках о великанах: “Косая сажень в плечах”. Удивительно совпадение древнеримской меры длины - "архитектур

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)дан одномерный массив. положительные элементы уменьшить в два раза, отрицательные заменить их индексами. 2)дан одномерный массив. найти произведение элементов массива. паскаль написать программу если можно блок схему
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

laleonaretouch
Lenuschakova1982316
koll23
oksanata777
Ушакова1902
Стадник620
adminaa
kalina1372
oledrag7
kseybar
anusha33325
perovd8111
ДеречинскийИрина1149
kronid12