maryariazantseva
?>

Составить программу на языке паскаль, которая запрашивает 3 числа (оценки), считывает их, находит средний , выводит результат на экран. 8 класс !

Информатика

Ответы

Викторович
Var
a,b,c:integer;s:real;
begin
writeln('Vvedite ');
readln(a,b,c);
s:=(a+b+c)/3;
writeln(s);
end.
igor-790

Под конфигурацией ПК понимают тот минимальный набор функциональных устройств и системных ресурсов, которые обеспечивают решение определенных задач и набор качеств которых доступен восприятию непрофессионального пользователя.

7.  устройства ввода информации – клавиатура, манипуляторы типа «мышь» и джойстик, сканер.
 устройства вывода информации – монитор с видеоадаптером, принтер, графопостроитель (типы, режимы работы, разрешающая быстродействие и пр.);

8. кратковременная – внутренняя память, состоящая из двух типов запоминающих устройств – оперативного (ОЗУ или RAM) и постоянного (ПЗУ или ROМ) (емкость области стандартного ОЗУ и емкость области расширенного ОЗУ, наличие зарезервированной памяти);
долговременная - внешняя память, которая представлена накопителями на гибких и жестких магнитных дисках (НГМД или FDD, НЖМД или HDD), на лазерных (оптических) дисках (количество устройств и их типы, поддерживаемая емкость носителя информации.

nchorich55

Алгоритм:

Должна быть переменная с суммой всех чисел (я её буду использовать как S)

1. Запрашиваем число (я его буду использовать как X)

2. Проверяем если S + X > 15 то (конец) иначе (повторяем 1 и 2 ещё раз)

Примеры на разных языках:

JavaScript:

var s = 0;

while (s < 15) {

s += input() //тут функция которая запрашивает и возвращает число

}

// действия после того как S > 15

Python:

s = 0

while s < 15:

   s += input('Введите число: ') //тут функция которая запрашивает и возвращает число

// действия после того как S > 15

P.S. Если что-то не понятно, я постараюсь объяснить подробнее.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке паскаль, которая запрашивает 3 числа (оценки), считывает их, находит средний , выводит результат на экран. 8 класс !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Olgachalova111
vova00831
mikek0906
Strelkov567
info40
Окунева-Мотова
aninepp
впвыпвып-Зуйков629
Cannabikh
Maksimova-Shorokhov303
ninaandreeva3179
lk1303
nzagrebin363
familumid
vovkiv7864