kate1610
?>

Basic: написать программу вычисления стоимости покупки состоящей из нескольких тетрадей и карандашей

Информатика

Ответы

petrosyan35
' Free Basic
Dim a as Double
Dim b as Double
Dim c as Integer
Dim d as Integer
print "Цена карандаша"
input a
print "Цена тетради"
input b
print "Количество карандашей"
input c
print "Количество тетрадей"
input d
print "Цена за все = "; a * c + b * d
Aleks0091
Согласно первому заданию надо сначала найти максимальный элемент

uses crt;
var x,y,z,max:integer;

Begin
writeln('Введите x y z');
readln(x,y,z);
if (x>y) and (x>z)
then max:=x
else
if (y>x) and (y>z)
then max:=y
else max:=z;

Writeln('max =',max);
Writeln('Младший разряд =',max mod 10);
Writeln('Остаток от деления на 3 =',(max mod 10) mod 3);

readln;
end.

2)

var n: Integer;
Begin
writeln('Введите день недели');
readln(n);
write('Уроков ');

case n of
1-4: writeln('6');
5,6: writeln('5');
7: writeln('нет');

end;
End.
ksenyabobrovich7214
Var
  i,j,n:integer;
  m: array[1..10,1..10] of integer;
  flag:boolean;
  sum: array[0..1] of longint;
 begin
  readln(n);
  flag:=true;
  for i:=1 to n do
   begin
    for j:=1 to n do
     read(m[i,j]);
    readln;
   end;
     //Проверяем строки
  i:=1;
  for j:=1 to n do
      sum[i mod 2]:=sum[i mod 2]+m[i,j];
  while ((i<n) and flag) do
    begin
     i:=i+1;
     for j:=1 to n do
      sum[i mod 2]:=sum[i mod 2]+m[i,j];
     if sum[0]<>sum[1] then flag:=false;
     sum[(i+1) mod 2]:=0;
    end;
    //Проверяем столбцы
  sum[0]:=0;
  sum[1]:=0;
  j:=1;
  for i:=1 to n do
      sum[j mod 2]:=sum[j mod 2]+m[i,j];
  while ((j<n) and flag) do
    begin
     j:=j+1;
     for i:=1 to n do
      sum[j mod 2]:=sum[j mod 2]+m[i,j];
     if sum[0]<>sum[1] then flag:=false;
     sum[(j+1) mod 2]:=0;
    end;
  sum[0]:=0;
  sum[1]:=0;
  j:=1;
  for i:=1 to n do
   begin
    sum[0]:=sum[0]+m[i,j];
    sum[1]:=sum[1]+m[n-i+1,j];
    j:=j+1;
   end;
  if  sum[0]<>sum[1] then flag:=false;
  if flag then writeln('Магический');
 end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Basic: написать программу вычисления стоимости покупки состоящей из нескольких тетрадей и карандашей
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Iprokopova81
a-lossev111
beglovatatiyana
AndreiAstakhva1442
mos-5nica
Баранов276
ramco1972
helenavalenti2846
Лежачёва355
byfetvostochniy
starabanov
axo-geo
missmorozova2
irinakiral
mail5