Sergei_sergei
?>

Составить программу на паскале. расчитать доход за весь гот по месяцам. пример: в первый месяц мы получили 100р, во второй 102р. но! учесть что и проценты тоже растут.

Информатика

Ответы

Yelena-Svetlana
// PascalABC.NET 3.3
// Cборка 1590 от 03.12.2017

begin
  var a:=ReadReal('Введите зарплату в первый месяц->');
  var z:=0.00;
  for var i:=1 to 12 do
   begin
    Writeln('Доход за ',i,' месяц составил ',a:0:2,'р.');
    z+=a;
    a:=a+a*0.1;
   end;
  Writeln('Зарплата за год: ',z:0:2,'р.');  
end.

Пример:
Введите зарплату в первый месяц-> 100
Доход за 1 месяц составил 100.00 р.
Доход за 2 месяц составил 110.00 р.
Доход за 3 месяц составил 121.00 р.
Доход за 4 месяц составил 133.10 р.
Доход за 5 месяц составил 146.41 р.
Доход за 6 месяц составил 161.05 р.
Доход за 7 месяц составил 177.16 р.
Доход за 8 месяц составил 194.87 р.
Доход за 9 месяц составил 214.36 р.
Доход за 10 месяц составил 235.79 р.
Доход за 11 месяц составил 259.37 р.
Доход за 12 месяц составил 285.31 р.
Зарплата за год: 2138.43 р

P.S Сделал как понял.
Курнев-Анастасия359
#include <iostream>
#include <cmath>
using namespace std;

void main() 
{
int n,sum=0; 
float y,k=0; 
cin >> n; 
int *mass = new int[n]; 
for (int i = 0;i < n;++i) 
{
cin >> mass[i]; 

for (int i = 0;i < n;++i) 

if (mass[i] >0 )
{
k++;
y=pow(mass[i],2); 
cout<<y;
sum+=mas[i]
}

system("pause"); 
}

2)#include <iostream>
#include <cmath>
using namespace std;

void main() 
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
kolesnikovaen
Однажды Ослик не знал чем заняться. Все его друзья уехали кто куда: кто к бабушке в деревню, кто на море теплое, а кто вообще в лес, ягоды собирать. И стало ослику скучно. Но вот он увидел книгу с ноутбуком, и думает. Думает, что бы выбрать. Если выберет книгу, то быстро ее прочитает и это ему не так тем более она скучная. Вот ноутбук другое дело - там и поиграть можно, и с друзьями пообщаться, и спросить что-нибудь в интернете, да узнать что-нибудь новое. Вот ослик и выбрал ноутбук. И стал играть в нем в игры. 
Так несколько лет. Ослик все играл, да играл, а его друзья уже давно себе нашли работу, завели семью и все у них хорошо. А ослик так и потратил половину своей жизни, а в дальнейшем и всю жизнь, на игру. Так что не играйте в игры, а учитесь, развивайтесь и читайте книги! Не будьте осликами.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на паскале. расчитать доход за весь гот по месяцам. пример: в первый месяц мы получили 100р, во второй 102р. но! учесть что и проценты тоже растут.
Ваше имя (никнейм)*
Email*
Комментарий*