ss2911
?>

Составьте программу на языке паскаль и так, вопрос по паскалю, сие не найти в интернете (ну по крайней мере мне) вопрос: как оператор case заключить в case. самое главное чтобы можно было сделать программу которая могла работать так: »выберите раздел »1- »2- »3- 1 »вы выбрали »выберите действие »1-узнать скорость »2-узнать путь 1 »введите время пути в часах и так далее там. если нужен пример кода то вот, но он не рабочий: var v, g, a, f: char; time: real; lenght: real; speed: real; begin writeln('выберите раздел: '); writeln('1-'); writeln('2-'); writeln('3-'); writeln('ваш выбор: '); readln(v); case v of '1' begin writeln('выберите действие'); writeln('1-узнать скорость'); writeln('2-узнать путь'); write('ваш выбор: '); readln(f); case f of '1': begin writeln('введите время пути в часах'); readln(time); writeln('введите длину пути в киллометрах '); readln(lenght); speed: =lenght/time; writeln('скорость=', speed: 5: 1, 'км/ч') end; '2': begin writeln('введите скорость движения в км/ч'); readln(speed); writeln('введите время пути в часах'); readln(time); lenght: =speed*time; writeln('путь=', lenght: 5: 1, 'км'); end else writeln('ощибка, такого пункта нет! '); end; end; end.

Информатика

Ответы

Nikolaevich
1) тут не поставил PROGRAM имя; var
2) case v of
"1" тут не поставил доветочие
3) else writeln(); тут не поставил end; один штуку, который закончит начала case f of
но ты краб его поставил до else я понял, а надо после, потому что else принадлежит не case v, а case f.

и всо он заработал вот код
modos201276

Инструмент поворота

Объяснение:

Использование инструмента «Поворот SketchUp» очень похоже на использование инструмента «Перемещение». Инструмент «Поворот» имеет трюк в рукаве, который большинство новых модельеров не обнаруживают до тех пор, пока они не смогли его использовать. Прежде всего, сначала:

Лучше предварительно выбрать. Как и в инструменте «Перемещение», вращение чего-то, что вы уже выбрали, обычно проще.

Инструмент «Поворот» также может делать копии. Нажмите клавишу Ctrl (Option на Mac), чтобы переключаться между поворотом оригинала или вращением копии. Вы также можете сделать несколько копий одновременно.

gaydukov5706

A=00

Б=01

B=10

Г=11


11 10 01 00
это доичный код чтобы его записать в шестнадцатеричном нужно разбить код справа на лева на тетрады это например 1111 - тоесть 4 знака.
справа налева разбиваеться для того что бы если в левом не будет хвотать знаков их дописать 0, тоесть если 11011 переводить в 16-ч, разобьеться вот так 0001 1011

 

 вашем случая 11100100 разобьеться так 1110   0100 

дальше по алгоритму нужно заменять тетрады на цифру из 16-ч.
1   0001   2   0010   3   0011   4   0100   5   0101   6   0110   7   0111

8   1000   9   1001   A  1010   B  1011   C 1100    D 1101    E  1110

F  1111

 

вот смотри значит 1110=E   0100=4
11100100=E4
 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу на языке паскаль и так, вопрос по паскалю, сие не найти в интернете (ну по крайней мере мне) вопрос: как оператор case заключить в case. самое главное чтобы можно было сделать программу которая могла работать так: »выберите раздел »1- »2- »3- 1 »вы выбрали »выберите действие »1-узнать скорость »2-узнать путь 1 »введите время пути в часах и так далее там. если нужен пример кода то вот, но он не рабочий: var v, g, a, f: char; time: real; lenght: real; speed: real; begin writeln('выберите раздел: '); writeln('1-'); writeln('2-'); writeln('3-'); writeln('ваш выбор: '); readln(v); case v of '1' begin writeln('выберите действие'); writeln('1-узнать скорость'); writeln('2-узнать путь'); write('ваш выбор: '); readln(f); case f of '1': begin writeln('введите время пути в часах'); readln(time); writeln('введите длину пути в киллометрах '); readln(lenght); speed: =lenght/time; writeln('скорость=', speed: 5: 1, 'км/ч') end; '2': begin writeln('введите скорость движения в км/ч'); readln(speed); writeln('введите время пути в часах'); readln(time); lenght: =speed*time; writeln('путь=', lenght: 5: 1, 'км'); end else writeln('ощибка, такого пункта нет! '); end; end; end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Aleksandrova Zhanna1250
АнастасияAndrey
elenakarpova709
ssitnickowa201244
adrinalin991
palosik7621
davidovalbert6
heodbxbbshe
Стадник620
Vs1377
Ерцкин_Овечкина391
sigidinv
saint158
koochma
devochkadafka624