sv455umarketing74
?>

1) напишите программу, вычисляющую значение функцию y=n(x+3x)^4-12xn+2n, для х и n введённых с клавиатуры. вычисление значения функции вынесите в отдельную процедуру. 2) напишите программу вычисляющую количество пар чисел, сумма которых четна 6 пар чисел вводится с клавиатуры ввода выберите сами) ! )

Информатика

Ответы

Lapushkin1988
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

procedure DimDimoch(x:real; n:integer; var r:real);
begin
  r:=n*Sqr(Sqr((x+3*x)))-12*x*n+2*n
end;

begin
  var x:real;
  var n:integer;
  Write('Введите x и n: '); Read(x,n);
  var r:real;
  DimDimoch(x,n,r);
  Writeln('Значение функции ',r)
end.

Пример
Введите x и n: -1.23 4
Значение функции 2410.83920384

begin
  Writeln('Введите 6 пар целых чисел');
  var k:=0;
  loop 6 do begin
    var (a,b):=ReadInteger2;
    if (a+b).IsEven then k+=1
    end;
  Writeln('Число пар с четной суммой: ',k)
end.

Пример
Введите 6 пар целых чисел
15 23
19 -7
5 0
4 11
132 63
444 12
Число пар с четной суммой: 3
nebo2020
1)Графический редактор–это программа, предназначенная специально для рисования и редактирования изображений. Точнее, программа позволяющая вам создавать настоящие шедевры живописи прямо на вашем компьютере, или редактировать уже за ранее готовые фотографии и изображения (простой пример возможностей редактора — убрать распространенный «эффект красных глаз»).
2)Растр — изображение, построенное из отдельных элементов (точек), как правило, расположенных регулярно. В большинстве приложений компьютерной графики, растровое изображение представляется двумерным массивом точек, цвет и яркость каждой из которых задаются независимо.
Пиксел — это наименьшая единица растрового изображения, получаемого с графических систем вывода информации (компьютерные мониторы, принтеры и т. д.)
4)Графический примитив - простейший геометрический объект, отображаемый на экране дисплея или на рабочем поле графопостроителя: точка, отрезок прямой, дуга окружности или эллипса, прямоугольник и т.п.
5)Векторная графика состоит из точек линий квадратов. Качество не ухудшается при увеличении. Используется в больших плакатах, гербах...
6)Качество растрового изображения зависит от размера изображения (количества пикселей по горизонтали и вертикали) и количества цветов, которые можно задать для каждого пикселя.
7)Растровая графика позволяет создать практически любой рисунок, вне зависимости от сложности, в отличие, например, от векторной, где невозможно точно передать эффект перехода от одного цвета к другому без потерь в размере файла.
Распространённость — растровая графика используется сейчас практически везде: от маленьких значков до плакатов.
Высокая скорость обработки сложных изображений, если не нужно масштабирование.
Растровое представление изображения естественно для большинства устройств ввода-вывода графической информации, таких как мониторы (за исключением векторных устройств вывода), матричные и струйные принтеры, цифровые фотоаппараты, сканеры, а также сотовые телефоны.
vinokurova88251
Program Task;
Const N = 499; M = 1;
Var A: Array [1..N, 1..N] of Boolean;
i, j, x, y, t: Integer;
b: Boolean;
Begin
Randomize;
While i < M Do
Begin
x := Random(N) + 1;
y := Random(N) + 1;
If A[x, y] = False Then
Begin
A[x, y] := True;
i := i + 1;
End;
End;
While b = False Do
Begin
b := True;
For i := 1 To N Do
For j := 1 To N Do
Begin
If A[i, j] = True Then
Begin
If (i + 1) <= N Then
A[i + 1, j] := True;
If (i - 1) > 0 Then
A[i - 1, j] := True;
If(j + 1) <= N Then
A[i, j + 1] := True;
If (j -1) > 0 Then
A[i, j - 1] := True;
End;
End;
For i := 1 To N Do
For j := 1 To N Do
If A[i, j] = False Then
b := False;
t := t + 1;
End;
WriteLn(t);
ReadLn;
End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) напишите программу, вычисляющую значение функцию y=n(x+3x)^4-12xn+2n, для х и n введённых с клавиатуры. вычисление значения функции вынесите в отдельную процедуру. 2) напишите программу вычисляющую количество пар чисел, сумма которых четна 6 пар чисел вводится с клавиатуры ввода выберите сами) ! )
Ваше имя (никнейм)*
Email*
Комментарий*
▲