tyrnaus
?>

Для заданного натурального n и действительного x подсчитать: s=1+1/sqrt(2)+1/sgrt(3)++1/sgrt(n) вот код программы, в чем ошибка? #include #include using namespace std; int main() { int n; float s=0, b=0; cout< < "n="; cin> > n; for (int i=1; i< =n; i++) {b=(1/sqrt(n)); s+=b; } cout < < "s="< return 0; }

Информатика

Ответы

adrinalin991
#include <iostream>
#include <cmath>
using namespace std;
int main() {
int n;
float s = 1,b = 0;
cout << "n=";
cin >> n;
for (int i=2; i<=n; i++){
    b=(1/sqrt(i));
    s += b;
}
cout <<"s="<< s << endl;
return 0;
}
dilanarthur27

class Person(object):

   def __init__(self, name = 'Bob', age = 25): #Значения по умолчанию заданы в конструкторе

       self._name = name  

       self._age = age  

   @property

   def name(self): #Свойство, возвращающее значение obj._name  

       return self._name

   

   @property

   def age(self):  #Свойство, возвращающее значение obj._age

       return self._age

   

   def say_hi(self): #Рандомный метод

       print(f'Hi, im {self._name}, im {self._age} yo')

   

   def set_age(self, value): #Метод для изменения значения свойства obj._age

       if value in range(1, 101):

           self._age = value

       else: raise RuntimeError('Bad Argument', f'Cant set age {value}, age must be in range [1, 100]')

Объяснение:

Второй класс попробуй реализовать сам

nsh25044

В ответе напишите буквы x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала – буква, соответствующая первому столбцу; затем – буква, соответствующая второму столбцу, и т. д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

Пример. Пусть задано выражение x → y, зависящее от двух переменных x и y, и фрагмент таблицы истинности:

Переменная 1 Переменная 2 Функция

??? ??? F

0 1 0

Тогда первому столбцу соответствует переменная y, а второму столбцу соответствует переменная x. В ответе нужно написать: yx.

Логическая функция F задаётся выражением (x ≡ z ) ∨ (x → (y ∧ z)).

Дан частично заполненный фрагмент, содержащий неповторяющиеся строки таблицы истинности функции F.

Определите, какому столбцу таблицы истинности соответствует каждая из переменных x, y, z.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Для заданного натурального n и действительного x подсчитать: s=1+1/sqrt(2)+1/sgrt(3)++1/sgrt(n) вот код программы, в чем ошибка? #include #include using namespace std; int main() { int n; float s=0, b=0; cout< < "n="; cin> > n; for (int i=1; i< =n; i++) {b=(1/sqrt(n)); s+=b; } cout < < "s="< return 0; }
Ваше имя (никнейм)*
Email*
Комментарий*