Александрович Андреевна
?>

Напишите программу, которая генерирует массив из случайных чисел от 20 до 85 в количестве не более 30 чисел. после этого необходимо посчитать количество чисел, больших введенного вами с клавиатуры. hellp решает игоговую оценку

Информатика

Ответы

blagorodovaanna375
Program n1;
const n=15;
var a: array[1..n] of integer;
i,b,k: integer;
begin
randomize;
write('массив: ');
for i:=1 to n do begin
a[i]:=random(66)+20;
write(a[i],' ');
end;
writeln;
write('введите число: ');
readln(b);
k:=0;
for i:=1 to n do if a[i]>b then k:=k+1;
write('k=',k);
end.
andreu420082132

в 3 раза

Объяснение:

V = K * i, где  

V - информационный объём изображения (размер файла, содержащего изображение)

K - количество точек (пикселей )

i - глубина цвета (число бит, используемых для записи цвета одного пикселя)

N = 2^i, где  

N - количество цветов в палитре

i - глубина цвета (число бит, используемых для записи цвета одного пикселя)

^ - знак степени

Т.к. изображение одно и тоже, то количество точек в них одинаковое (K).

2^i = 256

i = 8 бит для  p2.bmp

i = 24 бит для p1.bmp

Для p2.bmp  V = 8K

Для p1.bmp V = 24K

24 / 8 = 3

В 3 раза будет меньше информационный объём файла p2.bmp.

ЮлияНиколаевна1748
1.)
16 = 2^4
Получается, что рисунок p2.bmp - четырехразрядный, т.е. 1 пиксель занимает 4 бит памяти. 24/4=6. ответ: в 6 раз.

2.)
64*512=32768 - кол-во пикселей в изображении.
32 Кбайт = 32768 байт.
32768/32768=1 байт = 8 бит - память, занимаемая 1 пикселем.
2^8=256. ответ: 256 цветов.

3.)
25*30 см = 10*12 дюймов = 120 дюймов^2
10*12*300*300*3=32400000 байт = 31640 Кбайт = 30 Мбайт.
ответ: 30 Мбайт.

4.)
65536 = 2^16
1 пиксель занимает 16 бит = 2 байта.
1280*1024*2 = 2621440 байт = 2560 Кбайт = 2,5 Мбайт.
ответ: 2,5 Мбайт.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая генерирует массив из случайных чисел от 20 до 85 в количестве не более 30 чисел. после этого необходимо посчитать количество чисел, больших введенного вами с клавиатуры. hellp решает игоговую оценку
Ваше имя (никнейм)*
Email*
Комментарий*