sadinuraliev263
?>

Написать программу на паскале которая находит количество трёхзначных чисел делящихся на 14 и на 17 одновременно а также выводит эти числа на экран

Информатика

Ответы

Dmitrii1763

rogram zadanie1;

var

i:integer;

begin

for i:=100 to 999 do
Begin
if ( i mod 14 = 0 ) and ( i mod 17 = 0 ) 
then writeln(i);
end;

end.


ВРОДЕ как-то так


ldstroy
1. Короткий современный вариант ("один оператор")

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  Writeln('Sпол.неч = ',ArrRandom(50,-10,20).Println
    .Where((x,i)->(x>0) and (i.IsEven)).Sum)
end.

Тестовое решение
15 16 0 17 20 7 -3 -4 9 9 -3 -8 14 10 10 11 7 18 -8 8 0 15 1 4 11 1 9 -10 -7 -7 12 17 8 13 7 15 1 13 12 11 4 -5 -3 -6 -5 -10 -9 -8 8 -8
Sпол.неч = 148

2. Длинный "школьный" вариант ("почувствуйте разницу")

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
var
  a:array[1..50] of integer;
  i,s:integer;
begin
  Randomize;
  s:=0;
  for i:=1 to 50 do begin
    a[i]:=Random(31)-10; Write(a[i],' ');
    if (a[i]>0) and Odd(i) then s:=s+a[i]
    end;
  Writeln;
  Writeln('Sпол.неч = ',s)
end.

Тестовое решение
4 14 4 7 9 -4 3 6 20 -10 3 -3 15 12 9 0 3 12 13 -1 9 -2 -2 16 18 -2 5 9 17 -3 4 -6 10 10 -5 10 8 13 12 15 13 1 12 1 7 6 9 2 -9 -6
Sпол.неч = 207
Сорокина
1 задача

var
X_1, Y_1, X_2, Y_2, AC, BC, AB:real;
begin
writeln('Введите значания X_1 (точки A)');
readln(X_1);
writeln('Введите значания Y_1 (точки A)');
readln(Y_1);
writeln('Введите значания X_2 (точки B)');
readln(X_2);
writeln('Введите значания Y_2 (точки B)');
readln(Y_2);
AC:=X_2-X_1;
BC:=Y_2-Y_1;
AB:=sqrt((AC*AC)+(BC*BC));
writeln('Длинна отрезка AB равна ', AB);
end.

2 задача

var
A, B, C, P, S:real;
begin
writeln('Введите сторону A');
readln(A);
writeln('Введите сторону B');
readln(B);
writeln('Введите сторону C');
readln(C);
P:=(A+B+C)/2;
S:=sqrt(P*(P-A)*(P-B)*(P-C));
if(A+B<=C) or (A+C<=B) or (B+C<=A) then
writeln('Треугольник с такими сторонами не существует')
else
writeln ('Площадь треугольника по теореме Герона равна ', S);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскале которая находит количество трёхзначных чисел делящихся на 14 и на 17 одновременно а также выводит эти числа на экран
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Anait_Natalya451
myglassi26
mvinogradov6
margo55577869
Алексеевич949
kifstd
KseniGum9
slastena69678
Андрей628
Avolohova
Сергеевич1726
Maksim Lokhov
heodbxbbshe
Бабур
Тариелович871