type
base = record
id: integer;
ball: integer;
end;
var
t: text;
a: array of array of integer;
n: integer;
st, tmp: string;
err: integer := 1;
database: base;
begin
readln(n);
setlength(a, n);
for i: integer := low(a) to high(a) do
setlength(a[i], 2);
for i: integer := low(a) to high(a) do
begin
readln(st);
tmp := st;
delete(tmp, pos(' ', tmp, err), tmp.Length - pos(' ', tmp, err) + 1);
database.id := strtoint(tmp);
tmp := st;
delete(tmp, 1, pos(' ', tmp, err));
database.ball := strtoint(tmp);
a[i, 0] := database.id;
a[i, 1] := database.ball;
end;
var j: integer := 0;
assign(t, 'output.txt');
rewrite(t);
while (j <= high(a)) do
begin
if (j + 1 < high(a)) and (a[j, 1] = a[j + 1, 1]) then
if (a[j, 0] < a[j + 1, 0]) then begin
write(t, inttostr(a[j, 0])); write(t, ' '); write(t, inttostr(a[j, 1])); writeln(t,'');
write(t, inttostr(a[j + 1, 0])); write(t, ' '); write(t, inttostr(a[j + 1, 1])); writeln(t,'');
end else begin
write(t, inttostr(a[j + 1, 0])); write(t, ' '); write(t, inttostr(a[j + 1, 1])); writeln(t,'');
write(t, inttostr(a[j, 0])); write(t, ' '); write(t, inttostr(a[j, 1])); writeln(t,'');
end;
if (j+1=n) then
write(t, inttostr(a[j, 0])); write(t, ' '); write(t, inttostr(a[j, 1])); writeln(t,'');
inc(j, 2);
end;
close(t);
end.
Объяснение:
В 1945 году работала первая в СССР аналоговая машина. До войны же были начаты исследования и разработки быстродействующих триггеров — основных элементов цифровых ЭВМ.
29 июня 1948 года Председатель Совета Министров СССР И. В. Сталин подписал постановление, в соответствии с которым создавался Институт точной механики и вычислительной техники.
В 1948 году под началом доктора физико-математических наук С. А. Лебедева в Киеве начинаются работы по созданию МЭСМ (малой электронной счетной машины). В октябре 1951 года она вступила в эксплуатацию.
В конце 1948 года сотрудники Энергетического института им. Крижижановского И. С. Брук и Б. И. Рамеев получают авторское свидетельствона ЭВМ с общей шиной, а в 1950—1951 гг. создают её. В этой машине впервые в мире вместо электронных ламп используются полупроводниковые (купроксные) диоды. С 1948 г. Брук вёл работы по электронным ЦВМ и управлению с применением средств вычислительной техники.
В начале 1949 года в Москве на базе завода САМ были созданы СКБ-245 и НИИ Счетмаш. Создаются заводы «Счётмаш» в Курске, Пензе, Кишинёве.
Подробнее - на -
Поделитесь своими знаниями, ответьте на вопрос:
Плз решить по языку программирование python дано натуральное число n. составить программу, печатающую в порядке возрастания все не четные числа кратные 7 в промежутке [1..n]. число n вводится с клавиатуры.
=============