uglichwatch
?>

1. имеется пронумерованный список деталей: 1) шуруп, 2) гайка, 3) винт, 4) гвоздь, 5) болт. составить программу, которая по номеру детали выводит на экран ее название. с++

Информатика

Ответы

Кулагина_Владимир1179

#include <iostream>

#include <conio.h>

using namespace std;

void main()

{

       setlocale(LC_ALL, "Russian");

system("title Материалы");

       system("color 74");

       int material;

       start:

       system("CLS");

       cout << "Введите число для уточнение названия детали:\n";

       cin >> material;

       switch (material)

       {

       case 1: cout <<"Шуруп\n";

             break;

       case 2: cout<<"Гайка\n";

             break;

       case 3: cout<<"Винт\n";

             break;

             case 4: cout<<"Гвоздь\n";

             break;

             case 5: cout<<"Болт\n";

             break;

             default: cout<<"Предмет не найден\n";

                    break;

       }

                    getch();

       goto start;

       }

sebastianpereira994
#include

#include

void main(void)

{

clrscr();

int detal;

a:printf(«для получения названия детали введите номер (от 1 до 5) «);

scanf(«%d»,&detal);

switch(detal)

{

case 1:

printf(«шуруп»);

break;

case 2:

printf(«гайка»);

break;

case 3:

printf(«винт»);

break;

case 4:

printf(«гвоздь»);

break;

case 5:

printf(«болт»);

break;

default:

printf(«Ошибка ввода»);

goto a:

}

getch();

}
reception

I. Последовательность действий

- Выделить массив от a[l] до a[r], где a - сортируемый массив, а l & r - крайний левый и крайний правый сортируемый елемент

- Провести сравнение елементов попарно двигаясь слева на право, если первый елемент больше второго - необходимо поменять их местами

- Откинуть крайнеправый елемент из сортируемого участка

- Провести сравнение елементов попарно двигаясь справа на лево, если первый елемент меньше второго - необходимо поменять их местами

- Откинуть крайне левый элемент из сортируемого участка

- Повторить с начала пока не останется сортируемых элементов

II. Оптимизация

Выполнение абсолютно всех проверок (прохождение по всем под массивам) не является обязательным при наличии механизма определяющего является ли массив отсортированным. Таковым может служить флаг, который будет выставлен при отсутствии перемещений элементов в выделенном под массиве на текущей итерации сортировки. Если он выставлен, следующая итерация - не выполняется.

III. Пример сортировки

Элементы что находятся в текущем под массиве - выделены [] скобками.

Элементы что сравниваются в текущей итерации выделены ()

[(33 55) 25 7 16 45 22 30 41 83 12 17 31 77] | 33 < 55 -> пропускаем

[33 (55 25) 7 16 45 22 30 41 83 12 17 31 77] | 55 > 25 -> меняем местами

...

7 12 16 [17 22 25 30 31 (33 41) 45] 55 77 83 | 33 < 41 -> пропускаем

7 12 16 [17 22 25 30 31 33 (41 45)] 55 77 83 | 41 < 45 -> пропускаем

Так как на протяжении всего прохода по под массиву не было перемещений -> сортировка завершена.

(Полное решение представлено в прикрепленной картинке)

Кол-во сравнений при оптимизации сортировки: 71

Если считать кол-во сравнений в сортировке без оптимизации (либо в самом неудачном раскладе сорируемого массива) то его можно будет посчитать так:

кол-во сравнений 2n - 3 - для прохода по подмостиву туда и обратно (n - кол-во элементов массива)

кол-во сравнений в сортировке - сумма сравнений для прохода по каждому из под массивов туда и обратно

кол-во под массивов в массиве будет равно n / 2

Соответственно имеем формулу \sum_{i=n}^{i1}(2n-3)_{i};i=i-2, или же другими словами: сумма элементов (2i - 3) от i, где i = n, пока i > 1, когда i = i - 2.

Ну и переведем её на наш пример:

n = 14

i = n

(2 * 14 - 3) + (2 * 12 - 3) + (2 * 10 - 3) + (2 * 8 - 3) + (2 * 6 - 3) + (2 * 4 - 3) + (2 * 2 - 3) =

25 + 21 + 17 + 13 + 9 + 5 + 1 = 91

Кол-во сравнений при оптимизации сортировки: 91


Дан массив чисел: 33, 55, 25, 7, 16, 45, 22, 30, 41, 83,12, 17,31, 77 выполнить сортировку массива с
monenko

var

   d : array[,] of integer; // объявляем динамический массив

   a, b : integer;

begin

   write('введите размер массива: ');

   readln(a, b);

   d := new integer[a,b]; // задаем размер динамического массива

   for var i := 0 to a-1 do for var j := 0 to b-1 do d[i,j] := random(15); // заполняем массив случайными числами в диапазоне от 0 до 14

   for var i := 0 to a-1 do begin

       for var j := 0 to b-1 do begin

           if d[i,j] > 7 then begin // ищем первый элемент больше 7 в данной строке

               for var n := 0 to b-1 do if d[i,n] <= 7 then d[i,n] := sqr(d[i,n]); // заменяем все элементы больше 7 в данной строке

               break;

           end;

       end;

   end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. имеется пронумерованный список деталей: 1) шуруп, 2) гайка, 3) винт, 4) гвоздь, 5) болт. составить программу, которая по номеру детали выводит на экран ее название. с++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kyrtlab39
pnatalia
evamining
vintazhvintazh90
maxchemaxim14
Стадник620
olesya-cat8601
nadezhdasvirina
Golubovskayairina
andreevaanastsiyao82
gre4ka2004
АЛЕКСЕЙ
ooo-krasa
Vladimirovna Viktorovna
Vuka91