leonid-adv70
?>

Составить программу решения уравнения. напечатать исходные данные и результаты в принятом в виде. ax^2+bx+c< =0 1. программа должна правильно выполняться при любых значениях исходных данных. 2. правильность работы всех ветвей программы должна быть проверена на тестах. 3. при отсутствии решения или бесчисленном множестве решений должен быть напечатан соответствующий текст. например, неравенство решений не имеет или любое х является решением уравнения и т.п.

Информатика

Ответы

Olga1509

Весь программный код находится в прикреплённом файле. Язык реализации С++, если у Вас возникнут вопросы касательно кода, пишите, я Вам с удовольствием

kokukhin

Строка вводится с клавиатуры(максимум 99 символов). Первое слово должно быть с маленькой буквы или первая и последняя буквы этого слова не должны совпадать(иначе такое слово как Test не засчитается). Также будет засчитываться одна буква(abc d efg, буква d подходит, так как она и первая и последняя)

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strtok;
using std::strlen;

int main()
{
char a[100], *ptr;

cout << "Enter the string:" << endl;
cin.getline(a, 100);

cout << endl;

ptr = strtok(a, "., ");
while(ptr)
{
if(*ptr == *(ptr + strlen(ptr) - 1))
{
cout << ptr << ' ';
}

ptr = strtok(NULL, "., ");
}

cout << endl;

return 0;
}


Дана строка. найти в ней те слова, которые начинаются и оканчиваются одной и той же буквой. язык си+
Magnolia200872

1. ответ a)верно b)верно c)неверно d)верно e)верно

Объяснение: 1)ScanDisk-программа для исправления ошибок структур жестких дисков

2)Вследствие засорения реестра путем появления неверных записей, неочищенный кэш и мусор от установленных программ

3)Disk Cleanup-программа для очистки компьютера от всевозможного мусора, неиспользуемых системных файлов и следов работы в браузерах

4)Обычно программа перестаёт отвечать на действия пользователя, а курсор превращается в песочные часики. В этом случае в заголовке программы в скобках может быть написано «(Не отвечает)». Все попытки закрыть программу на «крестик» ничего не дают, либо крестик нажать не удаётся

5) Открыть диспетчер задач и во вкладке процессы снять задачу

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу решения уравнения. напечатать исходные данные и результаты в принятом в виде. ax^2+bx+c< =0 1. программа должна правильно выполняться при любых значениях исходных данных. 2. правильность работы всех ветвей программы должна быть проверена на тестах. 3. при отсутствии решения или бесчисленном множестве решений должен быть напечатан соответствующий текст. например, неравенство решений не имеет или любое х является решением уравнения и т.п.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

jaksonj326
чухловина209
zbellatriks
bulin2001
cat2572066
lenapopovich556510
владимировнаКлютко
NikolaevichIP1136
kiparistop
corneewa20096
Veronika1270
Марина1101
almihanika435
sv-opt0076
orinvarostov