stepa19806966
?>

На c++ напишите программу, которая находит все различные цифры в символьной строке. формат входных данных на вход программе подаётся символьная строка. формат выходных данных программа должна вывести в одной строке все различные цифры, которые встречаются в исходной строке, в порядке возрастания. если в строке нет цифр, нужно вывести слово 'no'.

Информатика

Ответы

kav511
// Если захочешь перенести массив из глобальных переменных, не забудь обнулить его

#include <bits/stdc++.h>

using namespace std;

bool a[10];
int main()
{
  string s;
  cin >> s;
  for (int i = 0 ; i < s.length(); ++i)
    if (isdigit(s[i]))
        {
          int ind = s[i]-'0';
          a[ind] = true;
        }
  bool fl = false;
  for (int i = 0; i < 10; ++i)
    if (a[i])
      {
        fl = true;
        cout << i << ' ';
      }
if (!fl)
        cout << "NO";

}
anchutk3016
1 Глобальная компьютерная сеть – это:
Г совокупность локальных сетей и компьютеров, расположенных на больших расстояниях и соединенных с каналов связи в единую систему.

2 Локальные компьютерные сети как средство общения используются только для:
г) осуществления обмена данными между несколькими пользователями, организации доступа к устройствам вывода и к общим информационным ресурсам местного значения.

3 Телеконференция – это:
в) система обмена информацией между абонентами компьютерной сети;

4 Компьютер, подключенный к Интернету, обязательно имеет:
а) IP-адрес;

5 Гипертекст – это:
б) структурированный текст, в котором могут осуществляться переходы по выделенным меткам;

6 Серверы Интернет, содержащие файловые архивы, позволяют
а) скачивать необходимые файлы;

7 Россия имеет следующий домен верхнего уровня в Интернете
б) ru;

8 Транспортный протокол (TCP) обеспечивает
а) разбиение файлов на IP-пакеты в процессе передачи и сборку файлов в процессе получения; (в учебнике написано так, но это неправда, конечно. TCP и IP - разные протоколы, TCP не требует наличия каких-то "IP-пакетов")

9 HTML (Hyper Text Markup Language) является:
а) средством создания Web-страниц;

10 Задан адрес электронной почты в сети Internet [email protected] Каково имя владельца этого электронного адреса?
б) user_name; (то, что стоит до собачки @ - имя, после - домен)

11 Модем – это:
г) техническое устройство.

12 Браузеры (например, Microsoft Internet Explorer) являются:
г) средством просмотра Web-страниц.

13 Почтовый ящик абонента электронной почты представляет собой:
б) часть памяти на жестком диске почтового сервера, отведенную для пользователя;
Михайлович_гергиевич315

Программы правда выводят не просто число, т.к. это не очень понятно получается, поэтому сначала выводится название того, что именно мы сосчитали.

Когда проверите работу программы, просто уберите текстовую часть вывода в конце, и тогда будет как в задаче- выводится только одно число.

Также, в последней программе можно сократить сообщение при отсутствии искомых чисел до просто "NO".

1) оканчивающиеся на 4 (минимальное):

цел ч,н,п,м=0

алг

нач

вывод "количество чисел в последовательности= "

ввод п

вывод "ввод последовательности натуральных чисел:", нс

нц для н от 1 до п

вывод "число ", н, " из ", п, " = "

ввод ч

если mod (ч, 10) = 4 то

если м=0 или м>ч то м := ч всё

всё

кц

вывод "минимальное число, оканчивающееся на четыре= ", м

кон

2) кратные 5 (среднее арифметическое):

цел ч,н=0,с=0,к=0

алг

нач

вывод "ввод последовательности натуральных чисел:", нс

нц

н := н+1

вывод "число №", н, " = "

ввод ч

если mod (ч, 5) = 0 и ч <> 0 то

с := с+ч

к := к+1

всё

кц при ч=0

если к=0 то

вывод "NO (нет чисел, кратных пяти)"

иначе

вывод "среднее арифметическое чисел кратных пяти= ", с/к

всё

кон


Напишите алгоритмы решения задач В КУМИРЕ Если не сложно, объясните почему?Напишите программу, котор
Напишите алгоритмы решения задач В КУМИРЕ Если не сложно, объясните почему?Напишите программу, котор

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На c++ напишите программу, которая находит все различные цифры в символьной строке. формат входных данных на вход программе подаётся символьная строка. формат выходных данных программа должна вывести в одной строке все различные цифры, которые встречаются в исходной строке, в порядке возрастания. если в строке нет цифр, нужно вывести слово 'no'.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vladimirovna1370
Lugovoi
denbelousov963
galtig83
lenapopovich556510
ЮлияДаниил520
cheshirsky-kot
egamedicalbuh
ИП-Сысоев1628
ovdei71
Наталья
Pervosha
yanermarina87
Кочугурова
Ионов202