#include <iostream>
#include <set>
#include <sstream>
#include <algorithm>
using namespace std;
int main(){
int n, num;
string line;
cout << "n = "; cin >> n;
set <int> yes;
set <int> no;
stringstream ss;
while(1) {
ss.clear();
getline(cin, line);
if(line != "HELP" && line != "YES" && line != "NO") {
ss << line;
continue;
}
if(line == "HELP") break;
if(line == "YES") {
while(ss >> num) {
yes.insert(num);
}
continue;
}
if(line == "NO") {
while(ss >> num) {
no.insert(num);
}
continue;
}
}
set <int> result;
set_difference(yes.begin(), yes.end(), no.begin(), no.end(), inserter(result, result.begin()));
for(auto it = result.begin(); it != result.end(); it++) {
cout << *it << " ";
}
return 0;
}
Дайте "лучший ответ" если решение правильное , у меня уже 1000 из но не могу набрать 5 лучших ответов
1) Модель Мальтуса - Согласно модели, предложенной Мальтусом, скорость роста пропорциональна текущему размеру популяции, то есть описывается дифференциальным уравнением: x ˙ = αx
2) Модель Бонхёффера—ван дер Поля - Модель, предложенную в статье Ричарда ФитцХью 1961 года, принято рассматривать как классический пример исследования концептуальных моделей быстро-медленных систем. В канонической форме она записывается как: εx ¨ + ( x² − 1 ) x ˙ + x − by − a = 0
3) Система хищник-жертва - Допустим, что на некоторой территории обитают два вида животных: кролики (питающиеся растениями) и лисы (питающиеся кроликами). Пусть число кроликов x {\displaystyle x} x, число лис y {\displaystyle y} y. Используя модель Мальтуса с необходимыми поправками, учитывающими поедание кроликов лисами, приходим к следующей системе, носящей имя модели Лотки — Вольтерры:
4) Дескриптивная модель: моделирование движения кометы - моделирование движения кометы вторгшейся в Солнечную систему, производится с целью предсказания траектории ее полета, расстояния, на котором она пройдет от Земли, и т.д. В этом случае цели моделирования носят описательный характер, поскольку нет никаких возможностей повлиять на движение кометы, что-то в нем изменить.
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу нахождения суммы всех двухзначных чисел которые делятся на 5
program nomer;
var x,s,i:integer;
begin
for x:=10 to 99 do
begin
if (x mod 5)=0 then s:=s+x;
end;
writeln(s);
end.