asemchenko
?>

Написать программу нахождения числа дней в месяце, если даны: номер месяца n – целое, также дано число а, равное 1 для високосного года и равное 0 в противном случае.

Информатика

Ответы

kchapurina591
Var
a:array[1..12]of integer;
m, n:integer;
Begin
a[1]:=31;a[7]:=31;
a[2]:=28;a[8]:=31;
a[3]:=31;a[9]:=30;
a[4]:=30;a[10]:=31;
a[5]:=31;a[11]:=30;
a[6]:=30;a[12]:=31;
Write('Введите номер месяца -> ');
Readln(m);
Write('Год високосный(1 - да || 0 - нет)?');
Readln(n);
if (m = 2) then Writeln(a[m] + n) else
  Writeln(a[m]);
end.
lion13
Var     n, m, sum: integer;   begin     sum : = 0;     repeat     writeln('введите числ с которого начинается ряд');     readln(n);     writeln('введите число которым заканчивается ряд');     readln(m);     until n< m;       if odd(n) then n : = n + 1;     if odd(m) then m : = m - 1;     sum : = (n + m) * (m - n + 2) div 4;     writeln('сумма чётных чисел натурального ряда: ', sum); end.
pafanasiew
Romanf romanf отличник 2013-01-10t16: 13: 22+00: 00 1. подумать над алгоритмом 2. вот сам алгоритм: а. спросить у пользователя значения б. расчитать ответ в. выдать ответ на экран 3. написать код в паскале 4. исправить ошибки компиляции 5. протестировать, вводить разные числа 6. обнаружила, что если вводить числа наугад ответ получается отрицательным иногда 7. вставить код проверки введенных пользователем значений 8. убрать ошибки компиляции 9. протестировать 10. готово а вот и сама программа: program aerobus; uses crt; const totalplace = 160; var businessplaces, economyplaces: integer; businessprice, economyprice: real; totalcharge: real; a,b: integer; correctinput: boolean; begin clrscr; businessplaces: =totalplace div 4; economyplaces: = totalplace - businessplaces; writeln('business places count: ', businessplaces); writeln('economy places count: ', economyplaces); correctinput: =false; while not correctinput do begin write('please input business class ticket price: '); readln(businessprice); if(businessprice> 0) then begin correctinput: =true; end else begin writeln('the price should be a positive number, please try again'); end; end; economyprice: =businessprice/2; writeln('economy ticket price is: ', economyprice: 0: 2); correctinput: =false; while not correctinput do begin write('how many business tickets are left? : '); readln(a); if(a> =0) and (a< =businessplaces)then correctinput: =true; if(a< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(a> businessplaces) then begin writeln('please input a number which is less or equal to the tolal business place count, please try again'); end; end; correctinput: =false; while not correctinput do begin write('how many economy tickets are left? : '); readln(b); if(b> =0) and (b< =economyplaces)then correctinput: =true; if(b< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(b> economyplaces) then begin writeln('please input a number which is less or equal to the tolal economy place count, please try again'); end; end; totalcharge: =(businessplaces-a)*businessprice; totalcharge: =totalcharge+(economyplaces-b)*economyprice; writeln('the total charge is: ', totalcharge: 0: 2); writeln; writeln('press enter to exit'); readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу нахождения числа дней в месяце, если даны: номер месяца n – целое, также дано число а, равное 1 для високосного года и равное 0 в противном случае.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vallium8354
rodin4010
mel9152480522
yuda12
Андрей628
klimovala2
platonm777639
starabanov
Любовь
Державина
mmihail146
slazurnaya
Бернард pokerman
ivanda