nordwokintos4
?>

Составьте программу которая выводит на экран числа от 1 до n

Информатика

Ответы

baton197310
Program Rick_and_Morty;
var n,i:integer;
Begin

write('введите n: ');
readln (n);

write('ответ: ');

for i:=1 to n do
begin
write(i,' ');
end;

writeln('');
writeln('конец');

end.
violetta152028
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
Writeln(Range(1,ReadInteger('n =')));
end.
irinaastapova2011
Процессор-это главный вычислительный электронный блок компьютера. Именно процессоротвечает за обработку всех данных в системе и глобально управляет работой аппаратного обеспечения компьютера.
клавиши- аппаратное обеспечение для ввода информации в компьютер
устройства ПК - портативный/персональный компьютер (устройство для сбора хранения поиска обработки информации)
файл-это упорядоченная совокупность данных, которая хранится на диске и занимает отдельную область внешней памяти.
Программноеобеспечение (ПО)— совокупность программ системы обработки информации и программныхдокументов, необходимых для эксплуатации этих программ.
документ Социальная информация, зафиксированная на любом материальном носителе в целях ее хранения, распространения и использования.
кегль- размер шрифта
жёсткий диск - устройство для хранения данных
папка-хранилище файлов разных типов
рабочий стол -основное окно графической среды пользователя вместе с элементами, добавляемыми в него этой средой
текст- цепочка закодированных символов
шрифт-это основа графического дизайна. Шрифт представляет собой определенное начертание знаков, их общее изображение и размер.
электронная почта-представляет собой один из связи между людьми. Любой пользователь локальной или глобальной сети, в которой предусмотрена соответствующая услуга, может послать «электронноеписьмо», то есть текстовое сообщение, которое по каналам связи передается от компьютера отправителя на компьютер адресата, где письмо будет находиться, пока его не прочитают. Передача сообщения происходит в течение очень короткого времени, исчисляемого несколькими минутами. 
носитель информации-место хранения информации например флешка
приложение-программа, предназначенная для выполнения определённых задач и рассчитанная на непосредственное взаимодействие с пользователем
операционная система- комплекс взаимосвязанных программ, предназначенных для управления ресурсами компьютера и организации взаимодействия с пользователем. 
Екатерина655
# coding: utf-8
# Python 3.X

'''
Вводятся четыре числа:
xa, ya: координаты ферзя
xb, yb: координаты другой фигуры

Координаты - целые числа
в интервале от 1 до 8.

Вывод - булево значение:
сможет ли ферзь побить фигуру
за 1 ход.
'''
def hits(xa, ya, xb, yb) -> bool:
    '''
    Проверка аргументов.
    '''
    args = (xa, ya, xb, yb)
    if any([not 1 <= z <= 8 for z in args]):
        raise ValueError("Неверные координаты!")

    '''
    На одной прямой.
    '''
    if xa == xb or ya == yb:
        return True

    '''
    Северо-западная диагональ.
    '''
    x_nw, y_nw = xa, ya
    while x_nw > 1 and y_nw > 1:
        x_nw -= 1
        y_nw -= 1
        if x_nw == xb and y_nw == yb:
            return True

    '''
    Юго-восточная диагональ.
    '''
    x_se, y_se = xa, ya
    while x_se < 8 and y_se < 8:
        x_se += 1
        y_se += 1
        if x_se == xb and y_se == yb:
            return True

    '''
    Юго-западная диагональ.
    '''
    x_sw, y_sw = xa, ya
    while x_sw > 1 and y_se < 8:
        x_sw -= 1
        y_sw += 1
        if x_sw == xb and y_sw == yb:
            return True

    '''
    Северо-восточная диагональ.
    '''
    x_ne, y_ne = xa, ya
    while x_ne < 8 and y_se > 1:
        x_ne += 1
        y_ne -= 1
        if x_ne == xb and y_ne == yb:
            return True

    return False # если не бьет

inp = [int(x) for x in input().split()]
if hits(*inp):
    print('YES')
else:
    print('NO')

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая выводит на экран числа от 1 до n
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergei_Olga658
Kochinev4
borisova-valeriya
a580028r
Грудинин604
palosik7621
silviya
tcmir
Дружинин
Наталья286
SAMSCHOOL96
det-skazka55
Александра Викторович531
100 нарисовать замок в паскаль абс ​
slitex
cosmetic89
▲