Тимур Андраниковна634
?>

Все свои напишите программу, которая определяет прямоугольный ли треугольник. на ввод программе длины сторон треугольника.

Информатика

Ответы

zaretskaya37
Var
a, b, c: real;
begin
  Read(a, b, c);
  if (a * a = b*b + c*c) or (b*b = a*a + c*c) or (c*c = b*b + a*a) then
    Writeln('Треугольник прямоугольный!')
  else
    Writeln('Треугольник непрямоугольный!')
end.

Пример:

3 4 5
Треугольник прямоугольный!
juliapierrat
Последовательности длиной 7, содержащей 5 букв А могут быть следующими:
** (* - любой из символов В или С)
*А*
ААА*АА*
АА*ААА*
А**
** (пока 6 вариантов)
Далее - аналогично:
**А
ААА*А*А
АА*АА*А
А*ААА*А
**А (ещё 5 вариантов)
ААА**АА
АА*А*АА
А*АА*АА
*ААА*АА (ещё 4 варианта)
АА**ААА
А*А*ААА
*АА*ААА (ещё 3 варианта)
А**
*А* (ещё 2)
** (ещё 1)
Итого: 6+5+4+3+2+1=21
Так как на месте * могут быть любые из 2 символов В или С, то это даст ещё по 4 варианта для каждого случая.
Можно здесь, конечно, комбинаторику вспомнить.
Итого: 21*4 = 84
priexali

Лента в Microsoft Word позволяет максимально быстро получить доступ к наиболее часто используемым командам. Лента содержит огромное количество команд, которые разбиты по смысловым группам. В этом уроке Вы узнаете, из каких вкладок состоит Лента, а также научитесь скрывать ее, чтобы увеличить рабочую область Word на экране монитора.

Если Вы ранее пользовались Word 2010 или 2007, тогда Word 2013 покажется Вам знакомым. В нем используются все те же Лента и Панель быстрого доступа, где можно найти команды для наиболее часто используемых задач, а также представление Backstage.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Все свои напишите программу, которая определяет прямоугольный ли треугольник. на ввод программе длины сторон треугольника.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Grishanin
anna-leonova
intermar2000
romka1210
manu95957
kush-2640
tip36
buriginast5
kiravalter1998697
ЮлияДаниил520
галина
whiskyandcola
Svatela37
missmorozova2
anastasiavilina
▲