Составить программу в паскале! известна стоимость 1 кг конфет, печенья, яблок. найти стоимость всей покупки, если купили х кг конфет, y кг печенья и z кг яблок.
Если i больше 0 делаем 1) i:= i(=5) - 1 = 5-1= 4 2) s:= 0+4(получилось в 1 действии)= 4 i больше 0, повторяем процедуру 1) i:= i(=4 из 1-ого решения) - 1 = 4-1= 3 2) s:= 4( из 1-ого решения) +3= 7 И еще раз 1) i:= i(=3 из 2-ого решения) - 1 = 3-1= 2 2) s:= 7( из 2-ого решения) +2= 7 + 2 = 9 Снова 1) i:= i(=2 из 3-ого решения) - 1 = 2-1= 1 2) s:= 9( из 3-ого решения) +1= 9+1 = 10 И еще 1) i:= i(=1 из 4-ого решения) - 1 = 1-1= 0 2) s:= 10( из 4-ого решения) +0= 10+0 = 10 Так как i= 0, а не больше 0, то алгоритм закончен S= 10
2. Подберите подходящий тип данных: a) Количество учеников в классе – integer, word, byte b)Заработанная плата сотрудника фирмы- real, double c) Фамилия сотрудника фирмы – string
3.Запишите арифметические выражения на языке программирования Паскаль: a) ac-b+xyz = a*c-b+x*y*z; в) a*x^2+b*x+c = a*x*x+b*x+c; c) (a-b)x+3/y+z = (a-b)*x+3/(y+z);
4) Напишите инструкцию вывода на экран: а) Вашего имени = write('Ваше имя'); В) Число 400 = write(400); С) Значение выражения x+y = write(x+y);
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу в паскале! известна стоимость 1 кг конфет, печенья, яблок. найти стоимость всей покупки, если купили х кг конфет, y кг печенья и z кг яблок.
k,p,i,s,x,y,z:real;
begin
write('Стоимость килограмма конфет: ');
readln(k);
write('Стоимость килограмма печенья: ');
readln(p);
write('Стоимость килограмма яблок: ');
readln(i);
write('Купили конфет: ');
readln(x);
write('Купили печенья: ');
readln(y);
write('Купили яблок: ');
readln(z);
s:=x*k+y*p+z*i;
write('Потратили всего: ',s);
readln;
end.