ser7286
?>

Написать программу на паскале к ученик 9 класса к уроку должен выучить наизусть три первые строфы первой главы романа а, с. пушкина «евгений онегин», содержащие 42 строки. сколько ему потребуется времени на выполнение этого , если первую строку он может запомнить за 5 секунд, а на запоминание каждой следующей строки ему требуется времени на 2 секунды больше, чем на запоминание предыдущей строки?

Информатика

Ответы

aureole6452

Var str , time, thtime: integer;

Begin

str := 42;

thtime := 5;

While str>0 Do

Begin

str := str-1;

time := thtime+time;

thtime := thtime+2;

End;

write(time,' секунд');

End.

Vrpeshka

Алгоритм такой:

1 шаг: определяем сколько мы получим денег за первые 75 газет.

Пусть n - всего газет, тогда (n-(n-75))*F = A, - рублей за первые 75 газет.

2 шаг: определяем кол.во копеек, которые мы получим за остальные газеты: (n-75)*X = B, - копеек.


Программа на естественном языке:

Переменные:

A, B : целые;

Начало

Введение n (число газет);

Введение F(цена за первые 75 газет);

Введение X(цена за последующие газеты);

A присвоить (n-(n-75))*F;

B присвоить (n-75)*X;

Вывод (Мальчик заработает A рублей B копеек).

Конец.

Исмагилова_Саният
((3 + 1) * 3) * 3 = 36 ((3) * 3 + 1 + 1 + 1) * 3 = 36 ((3) * 3 + 1 + 1) * 3 + 1 + 1 + 1 = 36 ((3) * 3 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1) * 3 = 36 ((3) * 3) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1) * 3 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1 + 1 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 ответ 16 def f0(number, log) #   v = 1   n = number + v   log += " + #{v}"   # log += "[" + n.to_s + "] "   return [n, log] end def f1(number, log) #   v = 3   n = number * v   log = "(#{log}) * #{v}"   # log += "[" + n.to_s + "] "   return [n, log] end def countways(start_num, end_num, op_numbers, max_steps = 0)   ways = {}   ways.store(start_num.to_s, start_num)   max_steps = max_steps == 0 ? (start_num - end_num).abs : max_steps   count = 0   for steps in 1..max_steps           # puts "steps = #{steps}"           new_ways = {}           ways.each_pair{|log, num|                   for k in 0..op_numbers-1                           num1, log1 = f0(num, log) if k == 0                           num1, log1 = f1(num, log) if k == 1                           num1, log1 = f2(num, log) if k == 2                           if num1 == end_num                                   # and log.include? ('[8]')                           then                                   log1 += " = " + end_num.to_s                                   count += 1                                   puts log1                           elsif num1.between? (start_num, end_num)                                   new_ways.store(log1, num1)                           else                                   # log1 = log1 + " = " + num1.to_s + " bad "                                   # puts log1                           end                   end           }           # p [steps, ways.size, new_ways.size]           ways = new_ways   end   return count end

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскале к ученик 9 класса к уроку должен выучить наизусть три первые строфы первой главы романа а, с. пушкина «евгений онегин», содержащие 42 строки. сколько ему потребуется времени на выполнение этого , если первую строку он может запомнить за 5 секунд, а на запоминание каждой следующей строки ему требуется времени на 2 секунды больше, чем на запоминание предыдущей строки?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Batishcheva
Марюк-Мубариз
vovkiv7864
bd201188
tretyakovamarina201155
madjk
annakorolkova79
ella-rudenko
sabinina0578
Rudakova_Yana
nat63nesnova5
baranovaas
ksv89
sales
Nikita