arbekova
?>

Вкаждом углу комнаты сидела по кошке .у каждой кошки по х котят. сколько всего ног. составьте программу для решения и вывода результата на экран .

Информатика

Ответы

stailwomen31
Var     x,y:byte;

begin
  writeln('В каждом углу комнаты сидела по кошке.');
  write('У каждой кошки по х котят. Введите x=');
  readln(x);
  writeln('Сколько всего ног?');
  writeln();
 
  writeln('В комнате 4 угла, следовательно 4 кошки');
  writeln('4 кошки по ',x,' котят = всего ', 4*x ,' котят');
  //4 кошки + котята
  y:=4 + 4*x;
  writeln('Всего кошек и котят = ', y);
  writeln('следовательно ног у кошек и котят = ', 4*y );
end.

Вкаждом углу комнаты сидела по кошке .у каждой кошки по х котят. сколько всего ног. составьте програ
atupicyn754

#include <iostream>

#include <vector>

using namespace std;

void group_multiply(vector<int> &a, int l, int r, int x){

   for(int i = l; i <= r; i++)

       a[i] *= x;

}

signed main(){

   const int n = 10;

   vector<int> a(n);

   int num = 0, max_elem = -INT_MAX;

   for(int i = 0; i < n; i++){

       cin >> a[i];

       if(a[i] > max_elem){

           max_elem = a[i];

           num = i+1;

       }

   }

   group_multiply(a,n-5,n-1,num);

   for(auto &i:a)

       cout << i << " ";

}

maslprod

Вы извините, что здесь пишу, в графе для ответов. Хочу Вам просто и код, и скриншот прикрепить. Попробуйте этот код (комментарии условны, только для понимания). Три числа введите через пробел, в соответствии с логикой конечно же (смотрите комментарии для лучшего понимания):

# k - максимальное количество котлет на сковороде

# m - прожарка котлеты с одной стороны

# n - входное количество котлет

k,m,n = map(int, input().split())

time_am = 0

if (n <= k):

   time_am += 2*m

elif (n > k):

   while (n > k):

       time_am += 2*m

       n -= k

       if (n <= k):

           time_am += 2*m

           break

print(time_am)


Пайтон Я хотел выполнить задание на курсерах Тренировочное задание по программированию: Котлеты*

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вкаждом углу комнаты сидела по кошке .у каждой кошки по х котят. сколько всего ног. составьте программу для решения и вывода результата на экран .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Кирилл-Анна1023
kmr495270
Karpova
zrs-546
andreanikin
Галстян874
irinasolodova3
TrubnikovKlimenok926
Zhanibekrva Kandaurova
Усошина1059
nagas
zubareva23338
Владимирович_Намик59
iivanovar-da
veravlad