elena-kondyreva
?>

Напишите программу, которая заполняет матрицу случайными числами и находит максимальный элемент матрицы

Информатика

Ответы

Eduard Popik
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
  Writeln('*** Исходная матрица ***');
  var a:=MatrRandom(m,n,-99,99); a.Println(4); Writeln;
  Writeln('Max=',a.ElementsByRow.Max)
end.

Пример
Количество строк и столбцов в матрице: 5 8
*** Исходная матрица ***
  37  27  -8 -40 -85 -36  62  90
 -60 -14 -18   0 -50  77 -19 -36
  14 -98 -80  81  -8  83  84  26
 -65  74  12 -77 -84  -4 -51 -93
  94  34  45  23 -53 -55  55 -45

Max=94
annino
Создается матрица 10х10, заполняется случайными числами от 0 до 100, выводит исходную матрицу и Max элемент.
Напишите программу, которая заполняет матрицу случайными числами и находит максимальный элемент матр
sergeev-alp5
For i = 1 To 9
  For j = 1 To 9
    s$=String(i*j)
    if length(s$)=1 then s$="  "+s$ else if length(s$)=2 then s$=" "+s$
    Print s$;
  Next j
  Print
Next i
End

Результат работы программы:
  1  2  3  4  5  6  7  8  9
  2  4  6  8 10 12 14 16 18
  3  6  9 12 15 18 21 24 27
  4  8 12 16 20 24 28 32 36
  5 10 15 20 25 30 35 40 45
  6 12 18 24 30 36 42 48 54
  7 14 21 28 35 42 49 56 63
  8 16 24 32 40 48 56 64 72
  9 18 27 36 45 54 63 72 81

Замечание: таблица на самом деле ровная, это тут ширина пробела и ширина цифры различна, поэтому сдвиг.
mgrunova3966
  const n=5;
var a:array [1..n,1..n] of Integer; 
  i,max,ind,s,j:integer;
begin 
 s:=0;
  Randomize;
  for i:=1 to n do 
  for j:=1 to n do 
    a[i,j]:=Random(100)-50;
for i:=1 to n do
begin 
for j:=1 to n do
  write(a[i,j]:4); 
writeln; 
end; 
j:=6;
   for i:=1 to n do
   begin 
    Dec(j); 
   if a[i,j]<0 then   
   s:=s+a[i,j]; 
  end; 
max:=a[1,2];
 ind:=1;
 for i:=1 to n do 
 if Abs(a[i,2])>Abs(max) then
   begin 
    max:=a[i,2];
     ind:=i; 
 end;
  a[ind,2]:=s;
       Writeln; 
      Writeln; 
 Writeln('a)Summ: ',s); 
 writeln('b)Max: ',max); 
 Writeln; 
      Writeln('c)');
  for i:=1 to n do
begin 
for j:=1 to n do
 write(a[i,j]:4);
 writeln; 
end;
  readln;
end.

Дана матрица а(5,5). 1. найти сумму s отрицательных элементов расположенных на побочной диагонали. 2

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая заполняет матрицу случайными числами и находит максимальный элемент матрицы
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mihalewanadia20176987
ldstroy
gamolml
Филипп1054
shmanm26
rikki07834591
kampina1
evgeniy1988486
Ofelya1308
zrs-546
Maksimova1320
Aleksandr72
Бочкарева Горохова1652
Баринова
Tsibrova
▲