Сорокина-Светлана
?>

Написать программу.вот : с клавиатуры вводится натуральное число n.в зависимости от значения остатка r при делении числа на 5 вывести на экран число n в виде n=5к+r где r представить в словесной форме . нужно !

Информатика

Ответы

Likhomanova63
Var r:array [0..4] of string = ('ноль','один', 'два', 'три', 'четыре') ;
n, x:integer;
Begin
Write('n=') ;readln(n) ;
x:=n mod 5;
Writeln('n=5k+', r[x]);
Readln() ;
End.
shymilin19951783
Basic:
DIM tetradCount as INTEGER, oblojCount as INTEGER, price1 AS INTEGER, price2 AS INTEGER
CLS
INPUT "Введите кол-во тетрадей:"; tetradCount
INPUT "Введите кол-во обложек:"; oblojCount

price1 = tetradCount * 5
price2 = oblojCount * 3

PRINT "Стоимость тетрадей:"; price1
PRINT "Стоимость обложек:"; price2
PRINT "Общая стоимость:"; price1 + price2
END

C#:
Обычный класс, единственная директива препроцессора System, в методе main

int tetradCount, oblojCoubt, priceOne, priceTwo, priceSum;

Console.WriteLine("Введите кол-во тетрадей:");
tetradCount = int.Parse(Console.ReadLine());

Console.WriteLine("Введите кол-во обложек:");
oblojCount = int.Parse(Console.ReadLine());

priceOne = tetradCount * 5;
priceTwo = oblojCount * 3;
priceSum = priceOne + PriceTwo;

Console.WriteLine("Стоимость тетрадей: " + priceOne);
Console.WriteLine("Стоимость обложек: " + priceTwo);
Console.WriteLine("Общая стоимость: " + priceSum);
tarasova
"Школьный вариант" (чтобы помучиться):
// PascalABC.Net 3.0б сборка 1066
var
  s1,s2:string;
  p,q:set of char;
  i:integer;
  c:char;
begin
  Write('Введите первую строку: '); Readln(s1);
  Write('Введите вторую строку: '); Readln(s2);
  p:=[]; q:=[];
  for i:=1 to Length(s1) do Include(p,s1[i]);
  for i:=1 to Length(s2) do Include(q,s2[i]);
  p:=p*q;
  for c:=' ' to Chr(255) do
    If c in p then Write(c,' ');
  Writeln
end.
 
Тестовое решение:
Введите первую строку: Карл у Клары украл кораллы
Введите вторую строку: Клара у Карла украла кларнет
  К а к л р у

Современный вариант:
// PascalABC.Net 3.0б сборка 1066
begin
  var s1:=ReadlnString('Введите первую строку: ');
  var s2:=ReadlnString('Введите вторую строку: ');
  Writeln('Общие символы в строках: ',s1.Intersect(s2).Sorted);
end.

Тестовое решение:
Введите первую строку:  Карл у Клары украл кораллы
Введите вторую строку:  Клара у Карла украла кларнет
Общие символы в строках: [ ,К,а,к,л,р,у]

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу.вот : с клавиатуры вводится натуральное число n.в зависимости от значения остатка r при делении числа на 5 вывести на экран число n в виде n=5к+r где r представить в словесной форме . нужно !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

МихайловнаLarisa1150
natalyaionova
yurick2071488
delta88
korotaeva778898
Anastasiya
SEMENOV25352
flerbuket332
fixer2006
andreevaanastsiyao82
fil-vasilij90
Aleksei806
Olegovna Volkov
Azarova Anastasiya1707
is0019